Support » Plugin: WooCommerce » Site crashes when installing latest Woocommerce plugin version

  • Resolved waldbach

    (@waldbach)


    From my error log file:
    [Sat Apr 21 20:36:33 2018] [error] [client 5.132.30.86] PHP Notice: map_meta_cap was called <strong>incorrectly</strong>. The post type shop_order is not registered, so it may not be reliable to check the capability "edit_post" against a post of that type. Please see <a href="https://codex.wordpress.org/Debugging_in_WordPress">Debugging in WordPress</a> for more information. (This message was added in version 4.4.0.) in /home/ijslander/domains/manegedeijslander.nl/public_html/wp-includes/functions.php on line 4147

    As a result I can’t even run my Storefront theme anymore.

    I have contemplated erasing the woocommerce tables in the database, but rather not as I put a lot of work in it.

    I should also note I tried Woocommerce plugin with all other plugins removed and that didn’t help either.
    WP Debug doesn’t give any errors, I just get a blank page.

    Any help is much, much appreciated, we need to get this up and running asap!

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • That notice is probably not related; it’s not a fatal error.

    Try this: disable all WC related plugins. Switch to StoreFront. Enable WC. If that works, install plugins and activate your theme again.

    Plugin Support Andrew

    (@slash1andy)

    Automattic Happiness Engineer

    @waldbach were you able to do the test mentioned above? You can also remove the WooCommerce plugin using FTP, and then install again.

    Hi Soft79 & Andrew,

    I have not yet tried it. I did move the plugin with FTP already, but haven’t tried Soft79’s method yet. Once I’ve done that I will report back to this thread.
    Thanks for your responses and help.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Site crashes when installing latest Woocommerce plugin version’ is closed to new replies.