Support » Plugin: Genesis Connect for WooCommerce » Site Content Disappears (for real!)

  • Aloha Friends

    I just put together a brand new site, and Genesis Connect for WooCommerce is making my content disappear. As in gone, nowhere, disappeared completely off all the pages.

    I deactivated all the plugins, then reactivated them one by one until I found this. I can activate all my other plugins except GCFW, and the content is on the pages.

    The site is on shared hosting on iPage.com. Here’s my WordPress Configuration:

    WP Version : 4.8
    WPMU: No
    MySQL Version : 5.6.32
    WP Table Prefix : wp_dhme_
    PHP Version : 5.5.22
    Session Save Path : 4;/hermes/phpsessions
    WP URL: https://newageofsail.com
    Server Name : newageofsail.com
    Cookie Domain : newageofsail.com
    CURL Library Present : Yes
    Debug File Write Permissions : Writable
    PHP Version : 5.5.22
    PHP Memory Usage: 47.89 MB
    PHP Memory Limit : 256M
    PHP Max Upload Size : 20M
    PHP Max Post Size : 20M
    PHP Allow URL fopen : Off
    PHP Allow URL Include : Off
    PHP Display Errors : Off
    PHP Max Script Execution Time : 120 Seconds

    Genesis Parent theme and Metro Pro Child Theme 2.5.2, both downloaded as “latest” from StudioPress 7-15-17.

    Plugin Name, Version, and Plugin URLs
    All In One WP Security 4.2.8 https://www.tipsandtricks-hq.com/wordpress-security-and-firewall-plugin
    Genesis Simple Edits 2.2.0 http://www.studiopress.com/plugins/genesis-simple-edits
    Genesis Simple Sidebars 2.1.0 http://www.studiopress.com/plugins/simple-sidebars
    Genesis Title Toggle 1.7.1 http://www.billerickson.net/
    PayPal for WooCommerce 1.4.5.1 http://www.angelleye.com/product/paypal-for-woocommerce-plugin/
    Super Socializer 7.9.3 https://super-socializer-wordpress.heateor.com
    WooCommerce 3.1.1 https://woocommerce.com/

    I’m using the Genesis parent theme and Metro Pro Child theme 2.4.2 along with Genesis Connect for Woo on another site and not having any problems there.

    I’d like to use the plugin; I’ve purchased a bunch of StudioPress themes and add-ons over the years and this is the first problem I’ve ever had with any of them.

    Any ideas what’s going on?

    Aloha, Tim………

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Contributor Nick C

    (@modernnerd)

    Thanks for this detailed report, Tim.

    Does your PHP error log show any fatal errors that you can share here?

    Seeing a white screen after activating a plugin usually means a fatal error has occurred. I’d be happy to review your logs and help you to put this right.

    Thread Starter kaimana

    (@kaimana)

    Hi Nick

    Here’s what happens when I’ve got Genesis Connect for Woo ACTIVATED: my site pages (https://newageofsail.com/) show the full-width responsive header, the breadcrumbs, the sidebar, and the Super Social icon set in the widget at the top of the sidebar. The Super Social icon set at the bottom of the content is NOT visible. Also, the WP editor works and appears normal. There’s no white screen of death anywhere (seen dat before!); it’s just that the content DISAPPEARS off the page when GCFW is activated.

    Here’s what I’ve got when I’ve got Genesis Connect for Woo DEACTIVATED: site pages appear totally normal, all content is visible, and both the Super Social icon set in the widget at the top of the sidebar AND at the bottom of the content appear.

    I’ve got the following in my wp-config.php file:

    define(‘WP_DEBUG’, true);
    define(‘WP_DEBUG_LOG’, true);

    /* That’s all, stop editing! Happy blogging. */

    @ini_set( ‘log_errors’, ‘On’ );
    @ini_set( ‘display_errors’, ‘Off’ );
    @ini_set( ‘error_log’, ‘/public_html/error_php.log’ );

    And when I activate GCFW and do a forced reload of a page, NOTHING is showing up in my error_php.log file, and there are no new entries in the WP error.log file. But this shows up at the top of the sidebar on my pages:

    Notice: woocommerce_get_page_id is deprecated since version 3.0! Use wc_get_page_id instead. in /hermes/bosnaweb17a/b639/ipg.newageofsailcom/public_html/wp-includes/functions.php on line 3831 Notice: ss_do_one_sidebar is deprecated since version 2.1.0! Use dynamic_sidebar() with sidebars_widget filter instead. in /hermes/bosnaweb17a/b639/ipg.newageofsailcom/public_html/wp-includes/functions.php on line 3831

    When I deactivate GCFW and do a forced reload, the deprecation notice at the top of the sidebar disappears.

    Hope this helps!

    With Warm Aloha, Tim……..

    Thread Starter kaimana

    (@kaimana)

    I should have said “duh, it looks like I just have to edit the functions.php file”, but don’t know what filters to add to wc_get_page_id, if any, or how to insert the sidebars_widget filter configured properly either.

    Aloha, Tim……

    Plugin Contributor Nick C

    (@modernnerd)

    Thanks for your reply, Tim.

    Please could you set your WooCommerce cart and checkout page at WooCommerce → Settings → Checkout → ‘Checkout pages’?

    woocommerce cart and checkout settings

    (If you have not yet completed the WooCommerce setup to create your Cart and Checkout pages, you can first do that from WooCommerce → Status → Tools → Install WooCommerce pages.)

    After making this change, activating Genesis Connect for WooCommerce should no longer cause page content to disappear.

    The separate “woocommerce_get_page_id is deprecated” notice you mentioned will be resolved in a plugin update, and is safe to ignore for now once you disable debug mode on you public site.

    Thread Starter kaimana

    (@kaimana)

    Aloha Nick

    Thanks for the simple explanation; situation is now fixed.

    This is totally my fault: I last installed WooCommerce in 2015, and the version at that time auto-installed the Cart and Checkout pages. Current version doesn’t do so.

    Not knowing these two pages now had to be manually installed, or that I had to use the WC Setup Wizard to do so, they weren’t.

    Again, Thanks! Aloha, Tim………

    Plugin Contributor Nick C

    (@modernnerd)

    Well done for putting this right, Tim, and thanks for revising your review – we appreciate it!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Site Content Disappears (for real!)’ is closed to new replies.