Support » Plugin: Wordfence Security - Firewall & Malware Scan » Site connectivity error

  • Resolved dozingdog

    (@dozingdog)


    I am seeing this error in Tools->Diagnostics

    Connecting back to this site
    wp_remote_post() test back to this server failed! Response was: cURL error 35: error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure

    I stumbled across it looking for a reason for why ALL traffic is appearing to come through out host (Siteground) rather than the user’s actual IP. My own IP comes up as Siteground as well, which is obviously incorrect. Any help? I’m out of ideas.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Double checked the PHP environment, and this looks correct –

    Checking for OpenSSL support
    OK

    Checking OpenSSL version
    OpenSSL 1.0.2r 26 Feb 2019 (0x1000212f)

    Checking for cURL support
    7.59.0 (0x73b00)

    So why can I not connect back to the site? And will this affect how IPs are registered?

    Hey @dozingdog,

    Can you please check to make sure How does Wordfence get IPs are correctly identifying your IP? If it isn’t, can you please cycle through the options to see if it helps?

    https://www.wordfence.com/help/dashboard/options/#general-wordfence-options

    Please let me know.

    Thanks,

    Gerroald

    Hi Gerroald,
    Thanks for the response. Right now it is using this option – “Let Wordfence use the most secure method to get visitor IP addresses. Prevents spoofing and works with most sites. (Recommended)” – to get IPs, and it says that it is doing it correctly. However, the IP address it shows for me is incorrect (it shows an IP associated with the website host). The other options either fail or show the same incorrect IP. I’m not sure what else to try.

    Thanks,
    Stephanie

    Hi @dozingdog,

    This seems to be two different issues, one regarding certificates, and the other with IP detection.

    We have had some users report that *all* IP addresses are incorrect (the options within How does Wordfence get its IPs).

    Can you contact SiteGround support and ask them if your site’s settings are properly configured for inbound traffic?

    Dave

    What settings in particular should I be asking about?
    The site has been running for 4 years, and traffic has been consistently rising (and tracked closely).

    Hi @dozingdog,

    We’ve seen this before with SiteGround and they were able to quickly resolve it. They’ll likely know what to look for. You can share this thread with them for reference.

    Please let us know how it goes.

    Thanks,

    Gerroald

    Hi @dozingdog,

    Just following up on this thread. If you’re still getting the wrong IP address for all the available options, there’s nothing that you can change on Wordfence / WordPress to obtain the correct IP. You’ll need to reach out to SiteGround support to have them correct the issue on their end.

    Dave

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Site connectivity error’ is closed to new replies.