Support » Plugin: Jetpack by WordPress.com » Site conflict with Jetpack – crashes site on activation

  • Resolved darrelldv

    (@darrelldv)



    Hi, I’m having a similar problem.
    WP v4.4.1 http://www.emeraldlodgelearning.com
    I updated Jetpack, which had been working well and the site died (front and back ‘server error’)
    I’ve been trying all sorts via phpmyadmin and ftp and cpanel, various repairs, exports and imports, deleting ‘jetpack’ lines from the database etc.
    I’ve stripped the site back to just WordPress standard theme (2016) and jetpack as the only plugin installed, as soon as I activate the plugin the site dies.
    I’ve also tried manual installation with the same ‘server error’ result.
    I have set up a subfolder on a blank database where I have the theme and jetpack working, if I then link that installation to the database with all the posts we’ve done, the site dies.
    So the conflict appears to be with jetpack and the database – hence why I tried to delete all references via ftp and phpmyadmin.

    Errors on the dash currently read:
    Warning: strpos() expects parameter 1 to be string, object given in /home/emeraldl/public_html/wp-includes/functions.php on line 3898

    Warning: Illegal offset type in /home/emeraldl/public_html/wp-admin/includes/plugin.php on line 913

    Warning: trim() expects parameter 1 to be string, object given in /home/emeraldl/public_html/wp-admin/includes/plugin.php on line 632


    looking at the functions.php file lines 3897-3898, they read
    function validate_file( $file, $allowed_files = ” ) {
    if ( false !== strpos( $file, ‘..’ ) )
    return 1;
    see any issues there? I checked it matches the functioning sites functions.php file and they’re identical, so maybe not a real problem.

    Last error log at point of crash says:
    [17-Jan-2016 21:45:37 UTC] PHP Warning: strpos() expects parameter 1 to be string, object given in /home/emeraldl/public_html/wp-includes/functions.php on line 3898
    [17-Jan-2016 21:45:37 UTC] PHP Catchable fatal error: Object of class __PHP_Incomplete_Class could not be converted to string in /home/emeraldl/public_html/wp-content/plugins/jetpack/class.jetpack.php on line 1752

    Any clues, solutions or workarounds appreciated 🙂

    Thanks
    Darrell

    https://wordpress.org/plugins/jetpack/

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    [17-Jan-2016 21:45:37 UTC] PHP Catchable fatal error: Object of class __PHP_Incomplete_Class could not be converted to string in /home/emeraldl/public_html/wp-content/plugins/jetpack/class.jetpack.php on line 1752

    That seems to be the key information here. The problem could be linked by some of your database options, especially information about your active plugins.

    Could you try to add the following to your theme’s functions.php file, and let me know what appears in the footer of the “At a glance” widget, in your dashboard?

    function jeherve_check_active_plugins() {
    	$active_plugins = (array) get_option( 'active_plugins', array() );
    
    	echo 'Debug: ';
    	print_r( $active_plugins );
    }
    add_action( 'activity_box_end', 'jeherve_check_active_plugins', 99 );

    Thanks!

    Hi Jeremy,
    Thanks for the reply. If I did it right, it crashed the site.
    The page displayed:
    Fatal error: Call to undefined function add_action() in /home/emeraldl/public_html/wp-includes/functions.php on line 5180

    Took it out and the login came back.
    Does it help?

    Thanks
    Darrell

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Try adding the code in your theme’s functions.php, not in WordPress’ core file. You’ll find your theme’s functions.php file under wp-content/themes/carry-hill-original/functions.php.

    Sorry Jeremy,
    School boy error!

    Under at a glance it says:

    Debug: Array ( [0] => redux-framework/redux-framework.php [1] => LayerSlider/layerslider.php [2] => Ultimate_VC_Addons/Ultimate_VC_Addons.php [3] => akismet/akismet.php [4] => breadcrumb-trail/breadcrumb-trail.php [5] => bricklayer-content-builder/cbp-content-builder.php [6] => carry-hill-plugin/carry-hill-plugin.php [7] => contact-form-7/wp-contact-form-7.php [8] => events-made-easy/events-manager.php [9] => image-pro-wordpress-image-media-management-and-resizing-done-right/imagepro.php [11] => js_composer/js_composer.php [12] => mce-table-buttons/mce_table_buttons.php [13] => timetable/timetable.php [14] => WordPress-importer/wordpress-importer.php [15] => __PHP_Incomplete_Class Object ( [__PHP_Incomplete_Class_Name] => Alti_Watermark [version:protected] => 0.3 [plugin_name:protected] => alti-watermark [loader:protected] => __PHP_Incomplete_Class Object ( [__PHP_Incomplete_Class_Name] => Alti_Watermark_Loader [actions:protected] => Array ( [0] => Array ( [hook] => plugins_loaded [component] => __PHP_Incomplete_Class Object ( [__PHP_Incomplete_Class_Name] => Alti_Watermark_i18n [domain:Alti_Watermark_i18n:private] => alti-watermark ) [callback] => load_plugin_textdomain [priority] => 10 [accepted_args] => 1 ) [1] => Array ( [hook] => admin_menu [component] => __PHP_Incomplete_Class Object ( [__PHP_Incomplete_Class_Name] => Alti_Watermark_Admin [plugin_name:Alti_Watermark_Admin:private] => alti-watermark [version:Alti_Watermark_Admin:private] => 0.3 [messages:Alti_Watermark_Admin:private] => Array ( ) [size:Alti_Watermark_Admin:private] => ) [callback] => add_submenu_page [priority] => 10 [accepted_args] => 1 ) [2] => Array ( [hook] => admin_enqueue_scripts [component] => __PHP_Incomplete_Class Object ( [__PHP_Incomplete_Class_Name] => Alti_Watermark_Admin [plugin_name:Alti_Watermark_Admin:private] => alti-watermark [version:Alti_Watermark_Admin:private] => 0.3 [messages:Alti_Watermark_Admin:private] => Array ( ) [size:Alti_Watermark_Admin:private] => ) [callback] => enqueue_styles [priority] => 10 [accepted_args] => 1 ) [3] => Array ( [hook] => admin_enqueue_scripts [component] => __PHP_Incomplete_Class Object ( [__PHP_Incomplete_Class_Name] => Alti_Watermark_Admin [plugin_name:Alti_Watermark_Admin:private] => alti-watermark [version:Alti_Watermark_Admin:private] => 0.3 [messages:Alti_Watermark_Admin:private] => Array ( ) [size:Alti_Watermark_Admin:private] => ) [callback] => enqueue_scripts [priority] => 10 [accepted_args] => 1 ) ) [filters:protected] => Array ( [0] => Array ( [hook] => plugin_action_links_alti-watermark/alti-watermark.php [component] => __PHP_Incomplete_Class Object ( [__PHP_Incomplete_Class_Name] => Alti_Watermark_Admin [plugin_name:Alti_Watermark_Admin:private] => alti-watermark [version:Alti_Watermark_Admin:private] => 0.3 [messages:Alti_Watermark_Admin:private] => Array ( ) [size:Alti_Watermark_Admin:private] => ) [callback] => add_settings_link [priority] => 10 [accepted_args] => 1 ) ) ) ) )

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Thank you!

    It seems that WordPress can’t return a list of your active plugins; it all starts breaking with the Alti_Watermark plugin. Could you try to deactivate and delete it, and let me know if it solves the issue, or if the debug list above gets updated to list all plugins?

    Thanks!

    Hi,
    Thanks for the reply.
    That plugin isn’t listed and doesn’t have a folder in the wp-content/plugins folder either.
    For fun I installed it again and deleted it to see if it would do some sort of cleaning up, but no different.
    Dashboard says:…..

    Debug: Array ( [0] => redux-framework/redux-framework.php [1] => LayerSlider/layerslider.php [2] => Ultimate_VC_Addons/Ultimate_VC_Addons.php [3] => akismet/akismet.php [5] => breadcrumb-trail/breadcrumb-trail.php [6] => bricklayer-content-builder/cbp-content-builder.php [7] => carry-hill-plugin/carry-hill-plugin.php [8] => contact-form-7/wp-contact-form-7.php [9] => events-made-easy/events-manager.php [10] => image-pro-wordpress-image-media-management-and-resizing-done-right/imagepro.php [11] => js_composer/js_composer.php [12] => mce-table-buttons/mce_table_buttons.php [13] => timetable/timetable.php [14] => WordPress-importer/wordpress-importer.php [15] => __PHP_Incomplete_Class Object ( [__PHP_Incomplete_Class_Name] => Alti_Watermark [version:protected] => 0.3 [plugin_name:protected] => alti-watermark [loader:protected] => __PHP_Incomplete_Class Object ( [__PHP_Incomplete_Class_Name] => Alti_Watermark_Loader [actions:protected] => Array ( [0] => Array ( [hook] => plugins_loaded [component] => __PHP_Incomplete_Class Object ( [__PHP_Incomplete_Class_Name] => Alti_Watermark_i18n [domain:Alti_Watermark_i18n:private] => alti-watermark ) [callback] => load_plugin_textdomain [priority] => 10 [accepted_args] => 1 ) [1] => Array ( [hook] => admin_menu [component] => __PHP_Incomplete_Class Object ( [__PHP_Incomplete_Class_Name] => Alti_Watermark_Admin [plugin_name:Alti_Watermark_Admin:private] => alti-watermark [version:Alti_Watermark_Admin:private] => 0.3 [messages:Alti_Watermark_Admin:private] => Array ( ) [size:Alti_Watermark_Admin:private] => ) [callback] => add_submenu_page [priority] => 10 [accepted_args] => 1 ) [2] => Array ( [hook] => admin_enqueue_scripts [component] => __PHP_Incomplete_Class Object ( [__PHP_Incomplete_Class_Name] => Alti_Watermark_Admin [plugin_name:Alti_Watermark_Admin:private] => alti-watermark [version:Alti_Watermark_Admin:private] => 0.3 [messages:Alti_Watermark_Admin:private] => Array ( ) [size:Alti_Watermark_Admin:private] => ) [callback] => enqueue_styles [priority] => 10 [accepted_args] => 1 ) [3] => Array ( [hook] => admin_enqueue_scripts [component] => __PHP_Incomplete_Class Object ( [__PHP_Incomplete_Class_Name] => Alti_Watermark_Admin [plugin_name:Alti_Watermark_Admin:private] => alti-watermark [version:Alti_Watermark_Admin:private] => 0.3 [messages:Alti_Watermark_Admin:private] => Array ( ) [size:Alti_Watermark_Admin:private] => ) [callback] => enqueue_scripts [priority] => 10 [accepted_args] => 1 ) ) [filters:protected] => Array ( [0] => Array ( [hook] => plugin_action_links_alti-watermark/alti-watermark.php [component] => __PHP_Incomplete_Class Object ( [__PHP_Incomplete_Class_Name] => Alti_Watermark_Admin [plugin_name:Alti_Watermark_Admin:private] => alti-watermark [version:Alti_Watermark_Admin:private] => 0.3 [messages:Alti_Watermark_Admin:private] => Array ( ) [size:Alti_Watermark_Admin:private] => ) [callback] => add_settings_link [priority] => 10 [accepted_args] => 1 ) ) ) ) )
    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    That’s interesting. Although the plugin isn’t there anymore, it still pollutes the WordPress option that returns your list of active plugins, thus creating issues with all plugins that rely on that option, like Jetpack in this case.

    Is that a production site? Can you afford deleting that option, and in doing so deactivating all your plugins for a few minutes? That would clean things up and hopefully solve our problem.

    If you’re ready to give it a try, add the following to your theme’s functions.php file:

    function jeherve_delete_active_plugins() {
    	get_option( 'active_plugins' );
    }
    add_action( 'init', 'jeherve_delete_active_plugins' );

    Once you’ve done so, head over to the Plugins menu in your dashboard. You’ll notice that all your plugins are now deactivated. Remove the code snippet above from your theme’s functions.php, and activate your plugins back.

    Let me know if it helps.

    Hi Jeremy,

    I’d give anything a try right now, if you said running down the street throwing oranges at people would fix it, then I’d do it 🙂

    I added it to themes function.php after the other code you gave me, but plugin list looks the same, Ctrl F5’d it but all have the option to deactivate rather than activate.
    Did I miss something?

    Thanks
    Darrell

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Oh, my bad. Try the following code instead:

    function jeherve_delete_active_plugins() {
    	delete_option( 'active_plugins' );
    }
    add_action( 'init', 'jeherve_delete_active_plugins' );

    Hi,

    That did something. 🙂
    I selected the plugins and bulk applied ‘activate’ and I got a white page with: You do not have sufficient permissions to access this page.

    Reloaded wp-admin and it was fine, but of course all deactivated again, so removed script, then activated.
    Dashboard error at the top has gone 🙂
    At a glance now reads:
    Debug: Array ( [0] => redux-framework/redux-framework.php [1] => LayerSlider/layerslider.php [2] => Ultimate_VC_Addons/Ultimate_VC_Addons.php [3] => breadcrumb-trail/breadcrumb-trail.php [4] => carry-hill-plugin/carry-hill-plugin.php [5] => contact-form-7/wp-contact-form-7.php [6] => events-made-easy/events-manager.php [7] => js_composer/js_composer.php [8] => timetable/timetable.php [9] => wordpress-importer/wordpress-importer.php )

    Let me know if it’s safe to try jetpack again.
    Thanks Jeremy.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    That looks a lot better! Alti_Watermark seems gone. You can try to activate Jetpack again. Hopefully you’ll be all set, and Alti_Watermark won’t have left other breadcrumbs somewhere else in your WordPress installation. If that’s the case, we can start considering your idea of running down the street throwing oranges at people. 🙂

    Let me know how it goes!

    Hi Jeremy,
    I think you saved the day… and saved me another evening mucking around!
    No need to waste those oranges. 🙂
    Thanks so much from all of us for helping,
    Darrell

    Hello Guys,

    Kindly help me out, I’m having similar issue

    Notice: bbp_setup_current_user was called incorrectly. The current user is being initialized without using $wp->init(). Please see Debugging in WordPress for more information. (This message was added in version 2.3.) in /hermes/bosnaweb26a/b2107/ipg.xxxxxx/wp-includes/functions.php on line 3897

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    @joeville9ja Your error is not related to this thread. This notice is displayed because you’ve enabled Debug in WordPress, as explained here:
    https://codex.wordpress.org/WP_DEBUG

    The notice mentions the specific function causing the issue, bbp_setup_current_user. That function is part of the bbPress plugin (or BuddyPress, if you use BuddyPress and bbPress). It’s a known issue, and you can learn more about it here:
    https://buddypress.trac.wordpress.org/ticket/4830

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Site conflict with Jetpack – crashes site on activation’ is closed to new replies.