Support » Plugin: Yoast SEO » Site coming off index

  • Resolved jdphoenix

    (@jdphoenix)


    A while back I received a “message on Yoast that the Permalink structure has changed and needed to be updated”. I figured it was just to refresh on YOAST, so I updated. Now a month later our pages are falling off the index. Why is this happening? Very concerned and hope YOAST has an answer to resolve this. We have put alot of hard work into our SEO. We have no other plugins related to this. Any help would be greatly appreciated.

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Thread Starter jdphoenix

    (@jdphoenix)

    ALSO, I noticed GOOGLE search console was listing my “user defined canonical” for the noted page above as “https://www.allvalleytransportation”, so I added the correct canonical in the YOAST option for this.

    NOTE: I did this on another page and Google re-indexed the page. I’m just wondering why I have to manually enter it now. Its been working fine for years. That is why I question if the YOAST “permalink structure” update may have caused this.

    Hoping for some advice here. Thanks so much

    Plugin Support devnihil

    (@devnihil)

    @jdphoenix We’re sorry to hear you are experiencing this issue on your site. We’ve identified several concerns in your message and responded to each below:

    A while back I received a “message on Yoast that the Permalink structure has changed and needed to be updated”. I figured it was just to refresh on YOAST, so I updated.

    We understand you haven’t changed any permalinks structure of your site but you’re seeing the permalinks structure have been changed notice from Yoast SEO and it must give you a pause.

    From v15.1, the Yoast SEO plugin can now detect the home URL or permalink structure changes. And since it’s a significant change, Yoast SEO needs to run the SEO data optimization again. However, we understand that you haven’t changed anything related to the notice but you are seeing the notification and it’s confusing for you; we apologize for any inconvenience.

    Can you please confirm whether you have performed the SEO data optimization in the WordPress > SEO > Tools page on your site’s dashboard? If not, can you please run the relevant analysis to see if that resolves the notice for you?

    Furthermore, you can also choose to ignore the permalink change warning message and instead wait for a week or so, during which the Yoast SEO plugin will automatically process most of your content in the background.

    I noticed GOOGLE search console was listing my “user defined canonical” for the noted page above as “https://www.allvalleytransportation”, so I added the correct canonical in the YOAST option for this.

    ​By default the Yoast SEO plugin will output a canonical tag for every page/post on your site, and will use the permalink of that page/post for the canonical URL value. Normally, you would leave the Canonical URL value in the plugin blank by default and the canonical tag will automatically be set to the same value as the page’s permalink.

    If you are seeing the value of the canonical URL that is output for a page as different from the page’s permalink, but having not been set to a custom value in the Yoast SEO plugin settings, this may be caused by another plugin or theme interfering with the Yoast SEO’s plugin’s output. In that event, and all of your site’s other plugins and themes are up to date and the problem is still occurring, we would next recommend performing a conflict check.

    A plugin or theme conflict can sometimes cause functionality problems, errors, or unexpected behavior from the plugin. If you are unfamiliar with checking for conflicts, we have a step by step guide on how to check for conflicts available here: How to check for plugin conflicts.

    Test this on your development or staging site, if you have one. If not, we recommend using the Health Check & Troubleshooting plugin. This plugin allows you to run a conflict check without affecting normal visitors to your site.

    We also have additional information on using the canonical tag and in what situations to implement it at the following link: https://yoast.com/rel-canonical/.

    Thread Starter jdphoenix

    (@jdphoenix)

    Hello,

    The notice is no longer there because a month and a half ago I DID follow the message and selected UPDATE assuming Yoast was just doing a refresh.

    IMPORTANT NOTE: Before and after I updated, (to make sure the permalinks were correct), I checked the Permalink structure under the “General settings” portion of the WordPress admin. Nothing was changed so I figured it was okay. I then ran the optimization. What would the YOAST change if the permalink structure was unchanged before and after? I’m confused. How can we straighten this out? Should I re-run the optimization? Very concerned here.

    Also regarding the canonical tag, I added the desired URL to the Yoast settings and the page was re-indexed. You mentioned this is not recommended using Yoast? If I leave it empty again, I would assume GOOGLE would take it off again.

    I also ran the trouble shooter and nothing out of the ordinary showed up. It just stated “We do not have a Default theme installed”, which we do (2021 WordPress).

    Any help on this is greatly appreciated. Thank you

    • This reply was modified 6 months, 2 weeks ago by jdphoenix.
    • This reply was modified 6 months, 2 weeks ago by jdphoenix.
    • This reply was modified 6 months, 2 weeks ago by jdphoenix.
    • This reply was modified 6 months, 2 weeks ago by jdphoenix.
    • This reply was modified 6 months, 2 weeks ago by jdphoenix.
    • This reply was modified 6 months, 2 weeks ago by jdphoenix.
    • This reply was modified 6 months, 2 weeks ago by jdphoenix.
    Thread Starter jdphoenix

    (@jdphoenix)

    Hello,

    The notice is no longer there because a month and a half ago I DID follow the message and selected UPDATE assuming Yoast was just doing a refresh.

    IMPORTANT NOTE: Before and after I updated, (to make sure the permalinks were correct), I checked the Permalink structure under the “General settings” portion of the WordPress admin. Nothing was changed so I figured it was okay. I then ran the optimization. What would the YOAST change if the permalink structure was unchanged before and after? I’m confused. How can we straighten this out? Should I re-run the optimization? Very concerned here.

    Also regarding the canonical tag, I added the desired URL to the Yoast settings and the page was re-indexed. You mentioned this is not recommended using Yoast? If I leave it empty again, I would assume GOOGLE would take it off again.

    I also ran the trouble shooter and nothing out of the ordinary showed up. It just stated “We do not have a Default theme installed”, which we do (2021 WordPress).

    Any help on this is greatly appreciated. Thank you

    Plugin Support suascat_wp

    (@suascat_wp)

    @jdphoenix

    Nothing was changed so I figured it was okay. I then ran the optimization. What would the YOAST change if the permalink structure was unchanged before and after? I’m confused. How can we straighten this out? Should I re-run the optimization? Very concerned here.

    If you haven’t changed anything in the permalink settings, despite the message being shown then it’s an odd issue. However, in the rare case, this message could pop up and therefore, can be simply ignored. SEO Data Optimization can be run only if the button is prompted. The message should be gone over time.

    Also regarding the canonical tag, I added the desired URL to the Yoast settings and the page was re-indexed. You mentioned this is not recommended using Yoast? If I leave it empty again, I would assume GOOGLE would take it off again.

    Yes, by default Yoast SEO output the correct canonical on the page. You don’t need to input it custom unless otherwise you don’t want the main URL of the page to be indexed and instead let Google index the canonical URL.

    I also ran the trouble shooter and nothing out of the ordinary showed up. It just stated “We do not have a Default theme installed”, which we do (2021 WordPress).

    The troubleshooting plugin considers the TwentyTwenty theme as a default theme.

    Thread Starter jdphoenix

    (@jdphoenix)

    Thank you so much for the reply. Yes, I DID select “UPDATE” where YOAST prompted me to and then optimized. Before and after I did that, I checked the WordPress admin permalink settings (side column/general settings) and they did not change so I assumed everything was fine. I figured YOAST just needed to verify again.

    I noticed on GOOGLE SEARCH CONSOLE’s “coverage” section that the URL’s have been excluded due to “ALTERNATE PAGE WITH PROPER CANONICAL TAG”. When I inspected the URL, the “USER Selected Canonical” was set to the homepage. This is why I forced the canonical within YOAST to read the proper URL and the page was since re-indexed.

    This is what leads me to believe that by updating in YOAST search engines are using another URL as “canonical”. Again, I forced the canonical and the page was re-indexed (at least for now).

    I copied the findings below (before I forced the canonical).

    Any help on this is very appreciated. Thank you

    ————————————————————————————–

    Coverage – Alternate page with proper canonical tag

    `URL Last crawled
    Jan 28, 2022
    https://www.allvalleytransportation.com/mesa-limousine/

    Jan 24, 2022
    https://www.allvalleytransportation.com/event-services/

    • This reply was modified 6 months, 2 weeks ago by jdphoenix.
    Plugin Support suascat_wp

    (@suascat_wp)

    @jdphoenix

    From your recent response, I understand your setup is all good now with permalink message and optimization and if so no further actions are needed.

    Regarding canonical, we checked the page source of both pages and found that they have self-referencing canonical URLs which means Google will index the actual URL of the respective page. We expect no SEO concerns will arise as per the current expected canonical output.

    Thread Starter jdphoenix

    (@jdphoenix)

    Thanks so much for the reply. I updated this a month and a half ago. Could you please check again those URL’s again? I just changed the canonical back to being “blank” as recommended.

    I’m just wondering why the search console would be using the “USER DEFINED CANONICAL” as the homepage. Thoughts?

    Thank you

    Plugin Support Michael Tina

    (@mikes41720)

    Hi @jdphoenix

    We’re reviewing both URLs:

    https://www.allvalleytransportation.com/mesa-limousine/
    https://www.allvalleytransportation.com/event-services/

    we can confirm that they are self-referencing to the same URL in the canonical URL field in the page source, and that should indicate that these are the original and canonical pages. We’re not exactly sure why GSC would report a different canonical, but if you were to inspect and fetch for the updated information, it should show you the updated information and GSC should be able to parse the correct canonical URL.

    Plugin Support devnihil

    (@devnihil)

    We are going ahead and marking this issue as resolved due to inactivity. If you require any further assistance please create a new issue.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Site coming off index’ is closed to new replies.