Support » Plugin: Ultimate Auction for WooCommerce » Site broken when WooCommerce Simple Auction is active

  • Resolved wpgenie2

    (@wpgenie2)


    Hi,

    just heads up, we had support ticket where client installed WooCommerce Simple Auction ( https://codecanyon.net/item/woocommerce-simple-auctions-wordpress-auctions/6811382 ) along Ultimate WooCommerce Auction Plugin and site broke. Since Ultimate WooCommerce Auction Plugin is almost completely based on code from WooCommerce Simple Auction it causes conflicts with original WooCommerce Simple Auction plugin functions. We would urge author to properly add suffixes to all our functions so it does not cause fatal errors.

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Nitesh

    (@nitesh_singh)

    Hi,

    I’m not sure if you had investigated as to why are there any fatal errors. I’m guessing that both plugins are using same “product type” = auction within the code due to which there might be an error. Both plugins are entitled to do it and the user should deactivate the plugin he is not using to avoid errors.

    Also, we have added prefixes to our code to avoid any conflict and our logic might be same but it is NOT based on “Simple auctions” plugin.

    Regards,
    Nitesh

    Thread Starter wpgenie2

    (@wpgenie2)

    Hi,

    no, problem is that your functions are not properly prefixed and are overwritting ours which have exactly same names.

    As for not being based on WooCommerce Simple Auctions, I can send you some code comparison screenshots, but I guess it’s just code reuse since all of this is gpl anyway.

    We just wanted to say if you reuse code do it properly 🙂

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Site broken when WooCommerce Simple Auction is active’ is closed to new replies.