Support » Plugin: WooCommerce » Site broken in Chrome (SSL issue)

  • Resolved grantsdale

    (@grantsdale)


    I have two sites with the same problem. One of them is herojiujitsu.com.

    When you try to go to the site in Chrome, it first gives an SSL cert error, then when you go to advanced and through, it loads the page without CSS.

    If I deactivate WooCommerce, the site loads correctly.

    I do not have ‘force SSL’ turned on. I have tried turning it on and then back off. No change.

    I don’t want to buy an SSL cert because I don’t think that will fix the problem.

    Any ideas?

    https://wordpress.org/plugins/woocommerce/

Viewing 7 replies - 76 through 82 (of 82 total)
  • It’s a plugin that fixes the problem. It was made by Stefan Vasiljevic (he’s up here too).

    Read more here: https://wordpress.org/support/topic/fix-the-ssl-issue-in-chrome-44?replies=1#post-7217222

    The Original Plugin which Stefan simply copied and added unnecessary donation button in WordPress administration was suggested a few comments before:

    post-7211826

    The clean and now fine-tuned plugin can be found on GitHub with all necessary instructions:

    The Original WordPress Plugin to fix Chrom 44 issues

    Direct Download Link: Chrome_44_Fix.zip

    Cheers

    Hi guys,

    sorry if you have the impression i copied something. I spent the entire afternoon yesterday trying to diagnose what’s the issue with chrome, because half of my websites were broken, and as you already may know, my phone started ringing because my clients were outraged.

    So when i finally found what’s the issue by printing the $_SERVER var, the solution was very straightforward. I used this article to help me to write a plugin, and decided to add a donation box because I spent a lot of time on this one.

    Then some users pointed out on my twitter account that the plugin mixes http with https requests on websites that use SSL, and that you can’t dismiss the donation box notice. So i added a simple if !ssl() and a option to dismiss the notice.

    My goal isn’t to make money on this, it’s to help people who are having the same issue i had. Donations are optional, and everybody who feels that should donate he oe she can do it, either way i will use that money to help some other people that need it more then i do.

    I hope i cleared this with you, and i think we should sometimes work together on some projects.

    Someone know if Chrome 44 is Updated?

    Hello? Is not great to leave the ssl deactivated, I’m wrong?

    Hey, does anyone test 2.3.13 with multisites?

    In my two websites I have cut off the things in the file .htaccess for the Chrome fixing and……. Everything is ok!!
    Tell me if is the same for you!

Viewing 7 replies - 76 through 82 (of 82 total)
  • The topic ‘Site broken in Chrome (SSL issue)’ is closed to new replies.