Support » Plugin: WooCommerce » Site broken in Chrome (SSL issue)

  • Resolved grantsdale

    (@grantsdale)


    I have two sites with the same problem. One of them is herojiujitsu.com.

    When you try to go to the site in Chrome, it first gives an SSL cert error, then when you go to advanced and through, it loads the page without CSS.

    If I deactivate WooCommerce, the site loads correctly.

    I do not have ‘force SSL’ turned on. I have tried turning it on and then back off. No change.

    I don’t want to buy an SSL cert because I don’t think that will fix the problem.

    Any ideas?

    https://wordpress.org/plugins/woocommerce/

Viewing 15 replies - 16 through 30 (of 82 total)
  • Thread Starter grantsdale

    (@grantsdale)

    @obertscloud: I think you had a different issue than the rest of us. Followed your procedure, no change.

    The reason I think you have a different issue is because Firefox works fine for me and you said it didn’t.

    Yep. Just checked a site from a long time ago that had off-site checkout, so no SSL on the site. Broken in Chrome.

    Yes maybe my issues are different, I am able to get some sites to access in firefox, until i fix it, i cannot access it in chrome, but after clearing chrome cache and history and everything, chrome accesses fine.

    There must be something in one of the updates that messed up SSL, my hosting provider confirms this also, not a hosting issue a wordpress issue.

    I just had one glitch with one site, wouldn’t let me after uninstall of woocommerce, it would not let me activate it. i had to manually delete the files, and go back to the previous version of woocommerce with a manual upload then activate

    the bad thing now though is that my login and admin is non ssl, but i have 128k password

    I am wrong you guys are correct now i have issues no matter what with chrome, but with firefox it is ok for the first 4 sites i fixed

    Version 44.0.2403.61 beta-m (64-bit)

    i am going to uninstall chrome beta and see what happen

    Yes Will I think this is a bigger issue , what version of Firefox do you run im on 38.0.5

    but I just tried to login in with https in Firefox and i get the same error as chrome I tried three different versions of chrome and not found one working yet, but if I log in with http:// on Firefox im ok.
    Any site without woocommerce or a ssl plugin, chrome and firefox works fine with login and wp-admin in SSL

    @obertsclou Yep, 38.05 as well. Chrome 64 bit AND Chrome Canary

    Ok changed my chrome to x32bit Version 43.0.2357.130 m and I am getting in.

    By the way I have 64bit firefox, I will switch that back. Maybe something with 64bit is causing it.

    whoa I was liking the speed of x64 browsers .

    I contacted Google, WordPress and my host about this. Also disabled google chrome updates for now.

    Also Chrome 32 bit seems to break every so often like in 3 months, I always have to uninstall and reinstall, or it just gets ridiculously slow

    Checking further this guy says a non ssl plugin works towards the bottom of his post

    http://ithemes.com/codex/downloads/fix-ssl-non-ssl-links.zip

    and this link below goes over mixed content issues. Which is the problem at hand.

    https://managewp.com/wordpress-ssl-settings-and-how-to-resolve-mixed-content-warnings

    and last someone suggested clearing chrome cache but that didnt work

    i am back now that i have a x32 bit browser

    Thanks @obertscloud What was the blog post that had the link to that file? Just wanted to read it.
    THANKS!

    Firstly, sorry for my english, but I don’t understand your responses to the first post.

    Do you know the solution for Woocommerce problem? Thanks.

    I am having the same issue. Version 44.0.2403.61 beta (64-bit). Firefox (38.0.5) is working fine. One suggestion is to report the issue to Google. In Chrome select help > report an issue. .

    JESUS F**KING CHRIST (excuse my language) you wouldn’t have any idea on the lengths through which I’ve gone to arrive to this page, and to discover this bug. I have been at this for days, and I’m so glad I’m not alone in this.

    Please, if someone has any solution to this, please post. I manage a few sites and this is a big problem for me. I’m on Chrome Version 44.0.2403.61 beta-m (64-bit).

    @azn137 I feel for you. I burned a whole day on this issue. Either WooCommerce (Automattic) or Chrome needs to address this issue.

    I just spent another 2 hours trying to reverse engineer the plugin to see if there’s anything I could hack… no dice. There are too many files and places that call the is_ssl() function.

    I’ve reported the issue via Chrome, but I doubt they can do anything. This seems to me like a problem that has to do with WC.

Viewing 15 replies - 16 through 30 (of 82 total)
  • The topic ‘Site broken in Chrome (SSL issue)’ is closed to new replies.