Support » Plugin: WooCommerce » Site broken in Chrome (SSL issue)

  • Resolved grantsdale

    (@grantsdale)


    I have two sites with the same problem. One of them is herojiujitsu.com.

    When you try to go to the site in Chrome, it first gives an SSL cert error, then when you go to advanced and through, it loads the page without CSS.

    If I deactivate WooCommerce, the site loads correctly.

    I do not have ‘force SSL’ turned on. I have tried turning it on and then back off. No change.

    I don’t want to buy an SSL cert because I don’t think that will fix the problem.

    Any ideas?

    https://wordpress.org/plugins/woocommerce/

Viewing 15 replies - 1 through 15 (of 82 total)
  • If you don’t want to buy an SSL, you’ll want to access the site via http://herojiujitsu.com instead of https://herojiujitsu.com. You won’t be able to access it via https without an ssl. When I typed in herojiujitsu.com into the address bar, it loaded fine…appending http:// instead of https://.

    I’m also having this issue, it seems to be that even though you visit the website with http:// anything loaded with get_stylesheet_directory_uri() is over SSL.

    Only happens for me in Chrome 44.0.2403.61 beta-m (64-bit) – all other browsers are fine

    This appears to only happen on the beta version of Chrome

    shellburton: I am NOT trying to use HTTPS. I even said I don’t have force SSL turned on.

    chubbyninja:
    I’m using Version 45.0.2438.3 dev-m (64-bit) on one computer – doesn’t work. Using Version 43.0.2357.130 m (64-bit) on another computer – works.
    Using Version 45.0.2438.3 dev-m on a third – doesn’t work.

    It seems to be v44 and up. But if you deactivate WooCommerce, it works fine.

    Same issue here with WooCommerce activated (deactivated, the site works fine), although the weird thing is it happens on another site without Woocommerce. Just started happening.

    Same problem here, contacted my host 1and1 they said contact woocommerce. ALso cannot access in chrome or in firefox SSL is not in force mode, but with woocommerce activated , it forces wp-admin and wp-login to use ssl and gets ssl error, only way to disable is through php then reactivate plugins except woocommerce (wp-options active plugins delete all the info in php).

    anyone using wordpress seo ? i wonder if there is a conflict, or maybe its the wordpress version?
    woocommerce says purchase a SSL cert, but my host gives you ssl cert for free with my package

    @grantsdale: I agree, same issue here for only Chrome >= v44

    I found a temporary fix change your wp-config.php add these lines

    first make sure they are not there by wp-better-security
    make sure the values are false

    define(‘FORCE_SSL_ADMIN’, false);
    define(‘FORCE_SSL_LOGIN’, false);

    login from firefox or clear chrome cache then restart chrome

    that fixes login, doesnt fix woo commerce , the user goes to the store and cannot see anything ssl error this sucks

    maybe by changing manually the cart, checkout etc to http:// this will work.. I did a status check and force SSL is at – not turned on.

    i went to woo commerce under settings and checkout forced ssl, saved then unforced, now i can see the product pages
    they go to http:// not sure about checkout yet

    will try on a site i have free checkouts and reply back hope this is helping someone , i lost 1 week of sales due to this error, since the last woocommerce update

    Maybe something to do with WooCommerce’s function fix_server_vars()

    Hmmm. I was hoping it was because the two sites that are affected with me were because they’re on temporary URLs with the IP address being used for the URL- and no SSL up yet.
    Though it’s fine on a live website with SSL throughout.

    Ok so it is confirmed a bug by something with SSL and woo commerce, could be also a combination of using wp-better-security which can force a site SSL but here is how I fixed it

    I have 250 more sites to fix that use woocommerce.

    ** also i recommend backing up the database before you do this and backup your wp-config.php file

    ** also check every site you have that uses woocommerce, because i had customers trying to purchase things, they were getting to a page with an ssl error when they clicked on the product page, verify you can click on a product and complete an order, i have 250 sites to do this to, and I lost thousands of dollars in the last couple of days, I am not sure how long this was happening, but i think about 1 week since the last updates.

    *** also if you update a site with the next woocommerce update , recheck all of this.. if you have security plugins also recheck

    ** just to note Woocommerce says there are three default pages that need SSL that is from the Checkout on.

    1) I went into php to disable all plugins, this sucks, you have to go to mysql from your hosting control panel or cpanel, then php you have to select the database for which site is effected,
    myphpadmin click this find the table wp-options, scroll down, you might have to go more than 25 to the next page and find active plugins, then you can edit that entry and delete the contents, (although i cut and paste the contents into a text pad,but pasting it back wont reactivate the plugins)

    2) now you should be able to login, give a moment for the database to update. but before you login,
    edit your wp-config.php file towards the bottom after this /** Sets up WordPress vars and included files. */ add :
    define(‘FORCE_SSL_ADMIN’, false);
    define(‘FORCE_SSL_LOGIN’, false);
    you might want to search to make sure it doesnt exist and if it does make sure true is set to false, reload via fpt your wp-config.php file back

    3) pain stakingly now you can go re-activate all the plugins you had (remember the contents i cut and paste into a notepad, although it is hard to read you can read each one you had activated from this list).

    4) when you get to woocommerce, and activate this one, you should be ok, if not you did not do your wp-config.php file correct

    5) all is good, then go to woocommerce status, see if force ssl is on, that is your problem,
    i went to woocommerce settings set force to true, then saved then unchecked it to false and saved

    6) now i can see products, nothing is going to https:// by default..

    I dont know what caused this because some of my woocommerce sites are still ok. Maybe the update, going to try and figure it out, maybe woocommerce support has better ideas why.

    When there is a fix, you can take out the entries in wp-config.php

Viewing 15 replies - 1 through 15 (of 82 total)
  • The topic ‘Site broken in Chrome (SSL issue)’ is closed to new replies.