Support » Plugin: WordPress HTTPS (SSL) » Site Broken!! Error 310 (net::ERR_TOO_MANY_REDIRECTS):

  • We have an SSL certificate and are trying to secure all of the content on our site.
    When some areas of the site were still not showing as secure, we added this code to the functions.php file:

    define(‘WP_HOME’,’http://simplymusicteachers.com’);
    define(‘WP_SITEURL’,’http://simplymusicteachers.com’);

    Now the site is broken and we are unsure of how to fix it. It seems to be looping or trying to redirect somehow.

    Anyone have any advice??

    Thanks!

    SM

    site url: http://www.simplymusicteachers.com
    theme: Blogs MU
    WP Multisite install

    http://wordpress.org/extend/plugins/wordpress-https/

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Mike Ems

    (@mvied)

    Adding that to your wp-config.php wouldn’t do anything to help you. Are you even using WordPress HTTPS? Exactly what have you done? I would recommend undoing anything goofy and just letting the plugin handle it.

    Thanks.

    Plugin Author Mike Ems

    (@mvied)

    So you got it working?

    Uh, no, revoking the SSL certificate and starting over. Have tried a whole bunch of stuff and now every page on the site just redirects to the home page; can’t even log in.

    Plugin Author Mike Ems

    (@mvied)

    Depending on what you’ve done, it could be many things. I don’t think it’s putting those in your config, though; but I guess it’s possible. It’s impossible to say without seeing it myself. Let me know if you figure it out or not.

    Cool – thanks. I read on the codex here: http://codex.wordpress.org/Changing_The_Site_URL about adding that code to the config.php or functions.php file. I believe it is referenced in the FAQ section for this plugin.
    Thanks for your responses.

    SC

    Plugin Author Mike Ems

    (@mvied)

    It’s best to just change it in WordPress if you can. If you change your Site URL to HTTPS, things should work fine. You may not need the plugin at all. There’s no reason it shouldn’t work immediately if your server and certificate are set up correctly.

    Wish I had known that sooner in the process.. Only the home page will load now, and any other page clicked on is redirected to the home page again.

    I have totally broken the site and spent days trying to figure it out.

    Any recommendations?

    I have:
    disabled all plugins
    edited the DB through phpmyadmin changing https: back to http:
    changed the .htaccess file, then
    disabled the .htaccess file

    I am stumped.

    Thanks,

    SC

    Plugin Author Mike Ems

    (@mvied)

    It’s hard telling. If you want, you can email me at mike[at]mvied[dot]com. I’m available for hire and I’m sure I could fix it in no time. It’s just one of those things that’s kind of hard to troubleshoot/advise from the outside.

    I’m having the same problem.

    Hey Again Mike-
    I am trying to understand this stuff and I’m still not clear on the best solution.

    Since this is a multisite install, I am unable to change the url to https in the admin settings.

    It is a multisite install with one main site and one sub domain, hosted on Godaddy with a Wildcard SSL / UCC certificate.

    I am trying to figure out the best way to secure the site. I need some redirect magic here:

    domain.com to		https://domain.com
    www.domain.com		https://www.domain.com
    sub.domain.com		https://sub.domain.com
    www.sub.domain.com	https://www.sub.domain.com
    
    all forward to the same urls only adding in https://

    Does anyone have any advice on the best way to do this? Is this plugin a good solution?

    Thanks!

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Site Broken!! Error 310 (net::ERR_TOO_MANY_REDIRECTS):’ is closed to new replies.