Support » Plugin: Quick Event Manager » Site Broken After 8.4.2 Update

  • I recently updated the Quick Event Manager plugin on my client’s website, everything else had already been updated, but after updating this plugin I got an error and cannot access the website unless I disable the plugin via FTP.

    The error that is displayed when the plugin is active:
    Parse error: syntax error, unexpected T_STRING in /home/content/32/6200532/html/wp-content/plugins/quick-event-manager/quick-event-register.php on line 331

    Can you please help me with this issue? This client relies heavily on the events plugin working, and have quite a few new events that they need displaying on their site.

    • This topic was modified 5 years, 5 months ago by RachelHKay.
Viewing 7 replies - 1 through 7 (of 7 total)
  • Wordpress recommends using PHP version 7 but many hosts are still running version 5 which stopped being supported 3 years ago.

    Upgrade your php and the plugin will work.

    Thread Starter RachelHKay

    (@rachelhkay)

    I can verify that my client is running version 5.2.17, so we can try to update to version 7 to see if that works. Unfortunately I don’t have access to their hosting, so I’ve contacted them and am waiting for their reply.

    Wow!

    5.2 stopped being supported over 3 years ago!

    Thread Starter RachelHKay

    (@rachelhkay)

    Yes, they are running a very old theme that can’t be updated. I’ve been trying to get them to upgrade to a newer theme, but being a nonprofit, they are very busy, so it hasn’t been easy getting a new theme chosen.

    Not sure what else to suggest. There are a lot of features in PHP 5 that have been depreciated and a lot of function now included in PHP7 making it faster and more secure.

    Do you not have cpanel access? If so upgrading PHP is very easy, you don’t need to talk to the hosting company.

    Thread Starter RachelHKay

    (@rachelhkay)

    I recently gained access to my client’s hosting only to find out that they won’t have PHP 7 available for another couple of months. I was however able to upgrade their PHP to 5.6 for now. My client has a 5k run event that they need to get the word out for, they are a nonprofit, Dan’s House of Hope, so all donations they receive helps them to keep their doors open. Is there any way I could get an older version of the plugin that will work with PHP 5.6 while we wait for their hosting to have version 7 available?

    You can get older versions here: https://wordpress.org/plugins/quick-event-manager/advanced/

    But to not have php 7 available is crazy considering it was released back in 2015

    • This reply was modified 5 years, 4 months ago by Graham.
Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Site Broken After 8.4.2 Update’ is closed to new replies.