WordPress.org

Forums

WP CDN Rewrite
[resolved] site blank after activation (4 posts)

  1. James Revillini
    Member
    Posted 1 year ago #

    hi - I know this is a PHP error but my site's not generating an error log for some reason. wish I could contribute more. cheers.

    https://wordpress.org/plugins/wp-cdn-rewrite/

  2. ampli
    Member
    Posted 1 year ago #

    I am also having the same problem

    And this is the error log

    PHP Warning: Missing argument 3 for _doing_it_wrong(), called in /home//public_html//wordpress/wp-content/plugins/wp-cdn-rewrite/wp-cdn-rewrite.php on line 49 and defined in /home//public_html//wordpress/wp-includes/functions.php on line 3040

    PHP Fatal error: Class 'Voce_Settings_API' not found in /home//public_html//wordpress/wp-content/plugins/wp-cdn-rewrite/wp-cdn-rewrite.php on line 92

  3. ampli
    Member
    Posted 1 year ago #

    here is the solution

    go to the plugins folder

    open wp-cdn-rewrite.php

    and add

    if( ! class_exists( 'Voce_Settings_API' ) ) {
    require_once( $path_to_voce_settings_api . '/voce-settings-api.php' );
    }

    Now try activating the plugin it will work.

  4. Kevin Langley
    Member
    Plugin Author

    Posted 10 months ago #

    This should now be fixed with the latest version of the plugin.

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP CDN Rewrite
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.