Support » Plugin: W3 Total Cache » Site appears to lose css when W3TC is activated

Viewing 8 replies - 1 through 8 (of 8 total)
  • I’m having the same issue. When activated, my site loads fine in Chrome and IE explorers, but the stylesheet for the theme is missing in Firefox and other third-party browsers.

    I deactivated the plugin and my style sheet shows up. I tried manual minify and tried adjusting setting and nothing works. Seemed to work fine with the prior version of W3TC, but this newest update is what is causing the problems.

    Anyone know how to fix this? Is there a setting that is triggering this problem?

    I’ll probably de-activate the plugin so I can keep my style sheet until I figure out what is causing the bug. Please check out browsershots to see what I mean – you’ll see some pics look great, and some have the stylesheet gone:

    Site is:

    Are you using minify in automatic mode?
    Change it to manual, use the help wizard, include .css and .js files step by step and try which inclusion causes the problem. After you found the culprit, leave the .js and .css file out for this function/plugin out.

    Hey I figured this out today! It turns out to be a conflict with the CDN. If you go into your CDN file, click on “Host Theme Files” to ensure it is UNCHECKED. This is what was causing the issue. I assume it was something to do with a disagreement in minify & hosting on CDN.

    All seems to be working great now in all browsers. Back to using W3TC and feeling great!

    I hope this helps others who run into this issue.

    My website is SharpeFIT hosted with W3TC and MaxCDN


    Thanks to both for your help. I changed minify from automatic to manual mode and everything works great now. Thanks again.

    Hi there,

    As this thread still seems to be active, I am having a similar problem. I configured the settings on W3 using online configuration help. At first everything works great. The site runs faster for sure. But after a view hours and a few hundred views, it loses all CSS. Then I need to manually clear the cache and everything starts working again.

    I am not using minify of CDN. Does anyone have any thoughts about this?

    Good Thread,
    Same problem here with CSS totally broken. I haven’t run W3TC for a couple of months because of the issue.

    I’m looking forward to running the earlier fixes up the flag pole to see how it works.

    Will Update.
    Thanks everyone.

    Plugin Author Frederick Townes


    Anyone who enables minify needs to be aware of the fact that they could have issues with the minify process. It’s a standard web development practice and your code has to be done in a friendly way for this procedure. In the case that there’s a bug, we’ll fix it. Please submit a bug submission form from the support tab of the plugin and only disable minify itself, not the entire plugin.

    Thanks for the follow up Frederick, I appreciate it. I’m in the process of manually minify-ing and checking the “Template” code for errors.

    Thanks again.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Site appears to lose css when W3TC is activated’ is closed to new replies.