Support » Fixing WordPress » Site Admin – Upload

  • I’ve seen this question asked a number of times, but so far I haven’t seen it answered so I hope someone can help. On my Upload area of site admin, I am getting the following error message:

    “It doesn’t look like you can use the file upload feature at this time because the directory you have specified (home/goochie/public_html/wp-content) doesn’t appear to be writable by WordPress. Check the permissions on the directory and for typos.”

    I have already changed the permissions to 777 on every conceivable WP file. What else could this be?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Umm, Ask your host maybe or try Smartftp or flashfxp?

    make sure mod_rewrite is activated.

    my suggestions would be:

    1) change permission from 777 back to default, you don’t want people to know that your wp-content folder is writeable to anyone 🙂

    2) create a folder in your wp-content folder called images, my images – whatever you want

    3) add write permissions for this particular folder and make sure the path to it is included in the admin panel for both uploads and images.

    4) change the path from home/goochie/public_html/wp-content to:

    destination dir: home/goochie/public_html/wp-content/my-images

    URI of this dir:
    http://yourdomain/wp-content/my-images

    reply back after you’ve done that and let us know the out come. There are a couple of things you could try, but one step at a time. Don’t forget to set the correct htaccess permissions for write as well

    Looks like it’s back to the drawing board. I’ve followed directions step by step:
    1) Permissions are set at either 755 or 777, including my new folder…
    2) I’ve created a new folder: my-uploads, in wp-content, under public_html
    3) On my Site Admin/Miscellaneous Options, I’ve changed the Destination Directory to:
    home/goochie/public_html/wp-content/my-uploads
    and the URI to: http://goochiegirl.com/wp-content/my-uploads

    Still, nothing. Oh, and I have checked for typos. Any suggestions for Plan B?

    well I have the same error after my host changed my server… Everything was working fine, but after changing servers, I couldnot use the upload feature. the chmods of the directories are still same…

    bump. I searched thru the forum and many have this problem but none of them are solved.

    Im sure youve checked this, but just in case;
    Shouldnt “home/goochie/public_html/wp-content/my-uploads” have ‘/’ infront
    ie “/home/goochie/public_html/wp-content/my-uploads”

    yeah I checked it before its not the problem…

    Well you got me then. My only suggestion would be to install WP in another directory using a fresh mysql database and see what happens – not particularly helpful but it might rule out other problems, maybe.

    If you think you’ve setup Uploads correctly, and things still don’t work, check PHP.INI (on most Unix/linux boxes, it will be /etc/php.ini

    Inside, make *sure* that there is a line that reads:
    file_uploads = on

    (and definitely not “file_uploads = off”)

    That made it work here.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Site Admin – Upload’ is closed to new replies.