WordPress.org

Forums

The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

[resolved] Site Admin button is not displayed (18 posts)

  1. Lemonhead
    Member
    Posted 10 years ago #

    I have installed WP 2.0.2 and all seems well now, but my site admin button is not displayed. Any suggestions ?

  2. jaredquinn
    Member
    Posted 10 years ago #

    Add these somewhere on your theme... Where you want the links.


    <?php wp_register('',''); ?> | <?php wp_loginout(); ?>

  3. Lemonhead
    Member
    Posted 10 years ago #

    This is what I currently have, any idead ?

    <!-- begin sidebar -->

    <?php global $user_ID; ?>

    <div id="sidebar">

    <?php if ($user_ID) { ?>
    <h2><?php _e('User Options'); ?></h2>


    <?php } ?>

  4. jaredquinn
    Member
    Posted 10 years ago #

    Whats your URL?

  5. Lemonhead
    Member
    Posted 10 years ago #

    http://www.clanobrien.us

    id is temp and password is temp. You will beprompted twice for this info. This is another problem I recently experienced with being prompted twice for the id and password.

  6. Lemonhead
    Member
    Posted 10 years ago #

    Can someone take a look at this for me ?

    Thanks in advance ?

  7. Michael Bishop

    Posted 10 years ago #

    The double login you are referring to is not a WP login. You have password protected some directories, and either due to redirects or some other reason it's happening. You might inquire with your host about that.

    I'm seeing a login and password, along with a "remember me" check box. Also the submit button.

    I tried using temp/temp in that login area, and was redirected to http://www.clanobrien.us/blog/wp-login.php
    with an error:wrong user name.

    If you are not seeing the button, you might be in IE, and that might be the issue ala CSS or the coding.

  8. Lemonhead
    Member
    Posted 10 years ago #

    I am a doing a bad job of explaining this issue. When you initially go to my site http://www.clanobrien.us you are initiaaly prompted to put in the WEBSITE id and password twice. I relaize this NOT a WP issues and I am trying to resolve this issue.

    My WP issie is this. If I sign in to WP( I am an admin), the site admin button is not displayed. Why is this happening ?
    This worked previously.

    Thanks in advance.

  9. Michael Bishop

    Posted 10 years ago #

    So if you login you are not shown a site admin link to the dashboard?

  10. Lemonhead
    Member
    Posted 10 years ago #

    Correct, if i login to wp the site admin link is not displayed.

    I am also noticing that if you click on a post the page that gets displayed blank. The only change I recall is someone in the forum had me change my http://www.clanobrien.us/index.php file to the below:

    <?php
    /* Short and sweet */
    define('WP_USE_THEMES', true);
    define('WP_IN_ROOTDIR', true);
    require('./blog/wp-blog-header.php');
    ?>

  11. Lemonhead
    Member
    Posted 10 years ago #

    Now this is odd. I click on the Archives button and the Site Admin button appears.

  12. Lemonhead
    Member
    Posted 10 years ago #

    It appears once I sign into wp it is not recognizing that I am signed in, but if I clck onto another link on my sidebar then it seems to recognize that I am signed in and my site admin button appears.

  13. Lemonhead
    Member
    Posted 10 years ago #

    Should I try reinstalling WP ?

  14. Lemonhead
    Member
    Posted 10 years ago #

    Is there any thing I should review to determine why the site admin button does not appear after the initial sign-in ? If I later click on another link within the sidebar the site admin button appears. Thus I think that for some reason after I click on the submit button it is not running the below code:

    <!-- begin sidebar -->

    <?php global $user_ID; ?>

    <div id="sidebar">

    <?php if ($user_ID) { ?>
    <h2><?php _e('User Options'); ?></h2>


    <?php } ?>

  15. jefuchs
    Member
    Posted 10 years ago #

    My admin link is at

    http://mysite.com/wp-admin/

    And yours should follow a similar pattern.

    You can leave the link off your main site, and create a subdomain like... http://www.admin.yoursite.com that points to the admin page. Without the link on the main page, you'll look more professional.

    I have the link on my page, but that's to make it easy for my other blogger friend to post (but he never does).

    It's possible that you are using a template that intentionally left the link off.

  16. Lemonhead
    Member
    Posted 10 years ago #

    I can live without the site admin not displaying, but what about the code "Write Posts" that does not appear when my users sign-in. Does your solution above work for this ?

    Thanks in advance for your assistance ?

  17. Lemonhead
    Member
    Posted 10 years ago #

    Okay it now works. I changed "/" to "/blog" in the submit form and now site admin, write post, etc. appears. 2 questions though :

    1. Why does this work ? Below is the code.
    2. When someone types in http://www.clanobrien.us it will take them to http://www.clanobrien.us. Should it take them to http://www.clanobrien.us/blog ?

    <input type="hidden" name="redirect_to" value="/" /></form>

  18. Lemonhead
    Member
    Posted 10 years ago #

    I followed the tips found in http://codex.wordpress.org/Login_Trouble#Site_URL_Redirecting.

    My mistake was following the instuctions found in "Giving WordPress its own directory" There seems to be some type of conflict in the re-direct of forms when using this strategy.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.