Support » Plugin: The SEO Framework » [NSFW] Site Address (URL) General settings : Sitemap 404 error

  • “Enter the address here if you want your site home page to be different from your WordPress installation directory.”

    changed to
    i am getting a 404 error and i think it’s because i have over 3000 pages and posts because it worked ok with a site that has only 9 on the sitemap.

    How do i have fix on this..google and bing appoves the url [ redundant link removed ] but the sitemap will not load..404 error

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Sybre Waaijer

    (@cybr)

    Hello!

    This issue pertains to the NGINX configuration of your website. Please see the response here for a potential solution: https://wordpress.org/support/topic/sitemap-xml-returns-404/#post-11991013.

    You may also want to clear out Yoast’s sitemap configuration, and instead keep it close to the officially proposed template. The “This is cool because no php is touched for static content.” part is what you need to make any plugin work well on your site.

    I hope this helps for now. Let me know if you’re still struggling. Cheers!

    I do not use yoast i use The SEO Framework – WordPress plugin

    Plugin Author Sybre Waaijer

    (@cybr)

    Hello again!

    Since Yoast SEO is pertinent in the world of WordPress, many NGINX installer scripts automatically add rules for Yoast SEO (which they shouldn’t…) because the script creators notoriously don’t know how NGINX works. So, one way or another, they made their mark on your site.

    Nevertheless, that issue is an aside from the original issue: There’s an XML rule active in the NGINX script which disables PHP whenever an .xml tag is noticed. You’ll have to contact your hosting provider or dig through the NGINX scripts yourself to remove that behavior.

    Alternatively, you can use this endpoint to view the sitemap, and register that via Google Search Console and Bing Webmasters: /de/sitemap.xml-alt.

    You’ll quickly notice that the alternative sitemap endpoint seems blank, because the XSL stylesheet cannot be found because the NGINX scripts aren’t registered correctly. When you disable styling for the sitemap via The SEO Framework’s settings, you should be able to view the sitemap’s contents easily.

    WordPress and plugins require a very specific set of NGINX rules to work correctly. Please read the official WordPress documentation here to find out more: https://wordpress.org/support/article/nginx/

    Thanks for your help! I did disable styling and i did see the site map /de/sitemap.xml-alt but google cannot fetch it.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.