WordPress.org

Forums

[resolved] Site acting funny after install (10 posts)

  1. JG99
    Member
    Posted 5 years ago #

    Hello, I installed WordPress but now when I go to the URL of my site, I get the following page:
    -------------------------
    Index of /

    * cgi-bin/
    * images/
    * postinfo.html
    * wordpress/
    -------------------------
    Furthermore, when I try to log in, I get a 404 error page from my hosting provider. What's strange is that when I initially installed WordPress, I got that nice page showing my blog title and all that. Then I changed the password in the Settings area and all went to hell in a handbasket! Can anyone help? THANK YOU!

  2. chartinael
    Member
    Posted 5 years ago #

    well, indexing is obviously on.
    you wordpress install is in a subdir
    your wp-admin thus in subdir/wp-admin

    ok ...

    what is the path to the wp url and blog url in the db? does it coincide with your installation?

    also serversidewise ... have you got a redirect from your domain to the subdir? is that planned?

    does you blog show when you enter ....www.domain.tld/wordpress/
    can you log in that way?

  3. JG99
    Member
    Posted 5 years ago #

    what is the path to the wp url and blog url in the db? does it coincide with your installation? <--Could you elaborate on this a bit?

    also serversidewise ... have you got a redirect from your domain to the subdir? is that planned?<---I'm sorry, I don't understand this completely either!

    does you blog show when you enter ....www.domain.tld/wordpress/
    can you log in that way?<--Tried this, but it says "URL not found."

    I appreciate your help, sorry for my lack of ability in these areas!

  4. JG99
    Member
    Posted 5 years ago #

    Bringing to the top, hoping someone can provide further details!

    THANK YOU.

  5. cubecolour
    ɹoʇɐɹǝpoɯ
    Posted 5 years ago #

    Bumping threads is against the rules here I'm afraid.

    When you changed the password did you also go into settings -> general & change the WordPress address (URL)? If so you need to edit the value in the database back to how it was.

  6. JG99
    Member
    Posted 5 years ago #

    Thank you for your advice - I am on another forum (not as good as this one, that's for sure), but one of the posters told me to do this:

    You have to put a redirect to your wordpress folder.

    Goto cpanel and click on redirects

    Select the domain set to http://yourdomain.com/wordpress

    Would you agree with this advice?

    Thank you again!

  7. JG99
    Member
    Posted 5 years ago #

    OK, so I ended up deleting the database and starting over...

    Now I have successfully completed the install and have the "Hello World!" new page in front of me.

    But my blog address is "http://www.mysite.com/wordpress"

    I am afraid if I change the settings in WordPress to simply

    "http://www.mysite.com" I will be right back where I was before.

    So do I need to first set up a redirect in cPanel?

    THANKS FOR YOUR HELP.

  8. cubecolour
    ɹoʇɐɹǝpoɯ
    Posted 5 years ago #

    But my blog address is "http://www.mysite.com/wordpress"

    I am afraid if I change the settings in WordPress to simply

    "http://www.mysite.com" I will be right back where I was before.

    Yes - but have a look at this article for the recommended solution:
    http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

  9. JG99
    Member
    Posted 5 years ago #

    This is how I solved the problem:

    Deleted my database in cPanel.

    Deleted wordpress files using cPanel file manager.

    At this point, "public_html" were empty. Deleted files _vti_inf.html and postinfo.html , and the directories cgi-bin, images and _vti_bin.

    Uploaded the ALREADY UNZIPPED wordpress files and directories (with their contents) to "public_html" using FileZilla.

    Then I followed the 5-minute install instructions on WordPress.org and now the blog is working perfectly and is in my root directory which means "www.mysite.com"

  10. neodan
    Member
    Posted 5 years ago #

    Glad to hear! Good luck with your new wordpress site.

    Just a reminder: Don't forget to make backups frequently!

Topic Closed

This topic has been closed to new replies.

About this Topic