Support » Networking WordPress » Site #1, 2 & 3 works but 4 does not?

  • Resolved NLBlackEagle

    (@nlblackeagle)


    I’ve tried editting my htaccess files aswell as wp-config.php files. Later on I found out that a plugin may be the cause so I disabled all the plugins and tried to make 2 new websites, I tried this and after taking a quick look both the websites did not work.

    However, after re-enabling all the plugins & themes one of the 2 new websites did started to work, could anyone explain me what might have happend? And how I should get my 4th website working?

    Extra Information:

    http://www.craftrealms.org ( Oldest )
    http://ark.craftrealms.org ( Age: 1 month )
    http://mc.craftrealms.org ( Just created & works )
    http://tc.craftrealms.org ( Just created & does not work )

    htaccess file:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    wp-config file:

    define('WP_ALLOW_MULTISITE', true);
    define( 'MULTISITE', true );
    define('ALLOW_UNFILTERED_UPLOADS', true);
    define('DB_NAME', 'wordpress');
    define('DB_USER', 'XXX');
    define('DB_PASSWORD', 'XXX');
    define('DB_HOST', 'XXX');
    define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', '');
Viewing 8 replies - 1 through 8 (of 8 total)
  • Tried:

    renaming plugin folder to:
    plugins.deactivated
    then did service httpd restart in putty terminal.

    Tried changing the htaccess file to the following data:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase eebees_com <--- THIS ALSO WRONG SHOULD BE /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    </IfModule>
    # END WordPress

    tried adding the following to the wp-config file:

    define('WP_ALLOW_MULTISITE', true);
    
    define( 'MULTISITE', true );
    
    define( 'SUBDOMAIN_INSTALL', false );
    
    define( 'DOMAIN_CURRENT_SITE', 'craftrealms.org' );
    
    define( 'SITE_ID_CURRENT_SITE', 1 );
    
    define( 'BLOG_ID_CURRENT_SITE', 1 );
    
    define('ALLOW_UNFILTERED_UPLOADS', true);

    Upon creating a website I now get the error:

    "Are you sure you want to do this?"

    This is a bug.

    I’ve completely re-installed wordpress from scratch and the issue still persists.

    It doesnt gives me the “Are you sure you want to do this?” error anymore but when I create a new website and navigate to it the page does not exist.

    Ignore the above post, after being directed towards “wildcard” I’ve went on a experimental tour and figured out that ark.craftrealms.org aswell as mc.craftrealms.org where listed as A record for two of my gameservers.

    This funcioned as a camonet over the fact that I didnt had a mctcp.craftrealms.org A record.

    Currently however it says that the page gets redirected in a wrong way, for as far as I know the whole main issue is solved but I will continue to experiment until everything works without flaws.

    Moderator Jan Dembowski

    (@jdembowski)

    Brute Squad and Volunteer Moderator

    It’s not a bug but there are problems with your setup.

    Your DNS either is not setup correctly or has not propagated yet for the 4th site. And it looks like your 3rd example isn’t working correctly.

    These are resolvable in DNS.

    www.craftrealms.org.    1799    IN      A       91.121.108.95
    ark.craftrealms.org.    1798    IN      A       91.121.108.95
    mc.craftrealms.org.     1799    IN      A       91.121.108.95

    The 4th one is not.

    tc.craftrealms.org

    The third and fourth site isn’t working correctly either so you may want to check your error logs.

    The main http://www.craftrealms.org/ site does work.

    Even without DNS working you can check on the command line with the curl --header command like this.

    $ curl -I --header "Host: ark.craftrealms.org" http://www.craftrealms.org/
    HTTP/1.1 200 OK
    Date: Thu, 04 Aug 2016 22:41:41 GMT
    Server: Apache/2.4.6 (CentOS) PHP/5.4.16
    X-Powered-By: PHP/5.4.16
    Set-Cookie: PHPSESSID=f82hcoa5nqajgccn2bvunnia37; path=/
    Expires: Thu, 19 Nov 1981 08:52:00 GMT
    Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
    Pragma: no-cache
    Link: <http://ark.craftrealms.org/wp-json/>; rel="https://api.w.org/"
    Link: <http://ark.craftrealms.org/>; rel=shortlink
    Content-Type: text/html; charset=UTF-8

    That’s a good response for the ark.craftrealms.org site.

    The 3rd site using that test doesn’t work exactly but does return headers. I’m not getting any HTML.

    ~$ curl -I --header "Host: mc.craftrealms.org" http://www.craftrealms.org/
    HTTP/1.1 200 OK
    Date: Thu, 04 Aug 2016 22:45:40 GMT
    Server: Apache/2.4.6 (CentOS) PHP/5.4.16
    X-Powered-By: PHP/5.4.16
    Set-Cookie: PHPSESSID=lb1ac9onvb4bnhrql7a1v9q7l5; path=/
    Expires: Thu, 19 Nov 1981 08:52:00 GMT
    Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
    Pragma: no-cache
    Link: <http://mc.craftrealms.org/wp-json/>; rel="https://api.w.org/"
    Content-Type: text/html; charset=UTF-8

    See the Link: line? That means WordPress received the request and says the site is known and exists. But it’s returning zero bytes to me after the headers.

    The 4th site does not seem to exist according to your multisite installation.

    $ curl -I --header "Host: tc.craftrealms.org" http://www.craftrealms.org/
    HTTP/1.1 302 Found
    Date: Thu, 04 Aug 2016 22:48:22 GMT
    Server: Apache/2.4.6 (CentOS) PHP/5.4.16
    X-Powered-By: PHP/5.4.16
    Location: http://www.craftrealms.org/wp-signup.php?new=tc.craftrealms.org
    Content-Type: text/html; charset=UTF-8

    The Location: line means that the main site www.craftrealms.org thinks tc.craftrealms.org does not exist in your multisite.

    Once you sort out the DNS and figure out why your network thinks tc.craftrealms.org doesn’t exist (remove and add it again) then you should be alright.

    It’s definitely the DNS.

    I’ve been playing a bit with existing A record, For example:

    ark.craftrealms.org
    mc.craftrealms.org
    play.craftrealms.org
    ts3.craftrealms.org

    Where already registered as A record years ago. I just only now added mctcp.craftrealms.org which probally needs some time to push through ( I guess & Hope )

    Anyway The upper posts are quite old already as I’ve been experimenting a whole lot and sadly in all the wrong places, I did gain some knowledge on the “Are you sure you want this?” error haha.

    Thanks alot for the discussing my issue as being directed towards DNS issues brought me a whole lot further as I came in the last +- 18 hours.

    Also, the only sites working properly are:

    ark.craftrealms.org
    http://www.craftrealms.org

    As they have everything installed, all other except mc.craftrealms.org dont even have a theme which is why there is the error page of missing theme and overall missing content, this is because I wanted the whole multisite confirmed working prior to moving on.

    Could you please check out what mctcp.craftrealms.org responds with?
    It would be of great help!

    Thanks a huge lot for seriously saving my day haha

    [Update]
    Now the mctcp.craftrealms.org gives a 400 bad Request

    A Record
    host: mctcp
    IP: 91.121.108.95
    TTL: Automatic ( I have absolutely no clue how long automatic takes )

    [Update]

    Normally, it takes 30 minutes for the settings to take effect. When the page refreshes, your domain will be automatically pointed to the Parking page.

    Well, that explains things. lets set that timer.

    Moderator Jan Dembowski

    (@jdembowski)

    Brute Squad and Volunteer Moderator

    The headers for that new site work.

    $ curl -I --header "Host: mctcp.craftrealms.org" http://www.craftrealms.org/
    HTTP/1.1 200 OK
    Date: Thu, 04 Aug 2016 23:39:42 GMT
    Server: Apache/2.4.6 (CentOS) PHP/5.4.16
    X-Powered-By: PHP/5.4.16
    Set-Cookie: PHPSESSID=4uq2dd67dhhscldt7kr39215t5; path=/
    Expires: Thu, 19 Nov 1981 08:52:00 GMT
    Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
    Pragma: no-cache
    Link: <http://mctcp.craftrealms.org/wp-json/>; rel="https://api.w.org/"
    Content-Type: text/html; charset=UTF-8

    But I’m still getting zero bytes for the HTML.

    Hooray,

    It took 30 minutes but everything works now!

    I’ve also assigned working Theme’s so you should get some bytes for the HTML now.

    Thanks alot for pointing me towards the right direction!

    Moderator Jan Dembowski

    (@jdembowski)

    Brute Squad and Volunteer Moderator

    You’re welcome. 😉

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Site #1, 2 & 3 works but 4 does not?’ is closed to new replies.