Support » Plugin: Site Kit by Google » Sit Kit installation > 404 after verification

  • Resolved Philcomputing

    (@philcomputing)


    I have tried to install Site Kit on a WordPress instance hosted by Sitegrpund. Since I already have Site Kit running on Siteground without problems, it doesn’t seem to be due to the listing.

    I have already searched forum for a solution. While there are a number of questions about this very problem, the answers did not help me to solve the problem.

    I have tried the following steps unsuccessfully:

    * Reset Site Kit
    * Temporarily deactivate any caching plugins you might have active
    * Install Site Kit in a new incognito window

    What else could be the reason?

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 21 total)
  • Enclosed my Site Health report

    
    ### wp-core ###
    
    version: 5.3.2
    site_language: de_DE
    user_language: de_DE
    timezone: +00:00
    permalink: /%postname%/
    https_status: true
    user_registration: 0
    default_comment_status: closed
    multisite: false
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /home/healthu4/public_html/sassen.org
    wordpress_size: 41,41 MB (43418822 bytes)
    uploads_path: /home/healthu4/public_html/sassen.org/wp-content/uploads
    uploads_size: 32,17 MB (33730849 bytes)
    themes_path: /home/healthu4/public_html/sassen.org/wp-content/themes
    themes_size: 5,24 MB (5492558 bytes)
    plugins_path: /home/healthu4/public_html/sassen.org/wp-content/plugins
    plugins_size: 57,28 MB (60058937 bytes)
    database_size: 9,36 MB (9814016 bytes)
    total_size: 145,45 MB (152515182 bytes)
    
    ### wp-active-theme ###
    
    name: Blocksy Child (blocksy-child)
    version: undefined
    author: Creative Themes
    author_website: (undefined)
    parent_theme: Blocksy (blocksy)
    theme_features: automatic-feed-links, title-tag, custom-logo, lifterlms-sidebars, editor-color-palette, post-thumbnails, woocommerce, html5, align-wide, customize-selective-refresh-widgets, post-formats, widgets
    theme_path: /home/healthu4/public_html/sassen.org/wp-content/themes/blocksy-child
    
    ### wp-parent-theme ###
    
    name: Blocksy (blocksy)
    version: 1.6.16
    author: CreativeThemes
    author_website: https://creativethemes.com
    theme_path: /home/healthu4/public_html/sassen.org/wp-content/themes/blocksy
    
    ### wp-plugins-active (12) ###
    
    Blocksy Companion: version: 1.6.7, author: CreativeThemes
    CoBlocks: version: 1.21.0, author: GoDaddy
    Contact Form 7: version: 5.1.6, author: Takayuki Miyoshi
    Flow-Flow: version: 4.1.26, author: Looks Awesome
    Getwid: version: 1.5.1, author: MotoPress
    Instant Images: version: 4.2.0, author: Darren Cooney
    LuckyWP Table of Contents: version: 2.0.7, author: LuckyWP
    Rank Math SEO: version: 1.0.38, author: Rank Math
    SG Optimizer: version: 5.4.3, author: SiteGround
    Site Kit by Google: version: 1.3.1, author: Google
    TinyMCE Advanced: version: 5.3.0, author: Andrew Ozz
    Visual Portfolio: version: 1.15.1, author: nK
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: 9.26
    
    ### wp-server ###
    
    server_architecture: Linux 3.12.18-clouder0 x86_64
    httpd_software: Apache
    php_version: 7.1.33 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 3000
    time_limit: 120
    memory_limit: 768M
    max_input_time: 120
    upload_max_size: 128M
    php_post_max_size: 128M
    curl_version: 7.59.0 OpenSSL/1.0.2r
    suhosin: false
    imagick_availability: false
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.6.40-84.0-log
    client_version: mysqlnd 5.0.12-dev - 20150407 - $Id: 38fea24f2847fa7519001be390c98ae0acafe387 $
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /home/healthu4/public_html/sassen.org/wp-content
    WP_PLUGIN_DIR: /home/healthu4/public_html/sassen.org/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 768M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    ### luckywp-table-of-contents ###
    
    domVersion: 20031129
    libxmlVersion: 2.7.8
    intlVersion: 1.1.0
    icuVersion: 4.8.1.1
    settings: {"lwptoc_general":{"min":"2","depth":"6","hierarchical":true,"numeration":"decimalnested","numerationSuffix":"none","title":"Inhaltsverzeichnis","toggle":true,"labelShow":"Anzeigen","labelHide":"Verbergen","hideItems":true,"smoothScroll":true,"smoothScrollOffset":"24"},"lwptoc_appearance":{"width":"auto","float":"none","titleFontSize":"default","titleFontWeight":"bold","itemsFontSize":"90%","colorScheme":"light","backgroundColor":null,"borderColor":null,"titleColor":null,"linkColor":null,"hoverLinkColor":null,"visitedLinkColor":null},"lwptoc_autoInsert":{"enable":true,"position":"beforefirstheading","postTypes":["post"]},"lwptoc_processingHeadings":{"postTypes":null},"lwptoc_misc":{"skipHeadingLevel":null,"skipHeadingText":null,"hashFormat":"asheading","hashConvertToLowercase":false,"hashReplaceUnderlinesToDashes":false,"wrapNoindex":false,"useNofollow":false,"showMetaboxPostTypes":null,"listMarkupTags":"div"}}
    
    

    Do you have Security plugin? If there is a option Filter long Url’s, you have to uncheck it. That worked for me

    @mikestankovich, thank you very much for your answer.

    Before reinstalling Site Kit I disabled all plugins.

    Plugin Support James Osborne

    (@jamesosborne)

    @philcomputing Thanks for reporting, the context is very useful. From the other sites which you have operating fine do they all have the same configuration?

    If you want to attempt setup once more please following the steps below:
    1. Reset Site Kit
    2. Delete the plugin in full from your WordPress install
    3. Temporarily deactivate the SG Optimizer & CoBlocks plugins
    4. Temporarily switch to a default WordPress theme (such as Twenty Twenty)
    5. Attempt setup once more from a browser incognito window

    @jamesosborne,

    thanks for your kind help. I followed your instructions:

    • The reset was not possible because this step is only shown after verification. Since I will be sliding to an error page during installation, I cannot perform the reset.
    • I have deleted Site Kit
    • I have temporarily disabled all plugins
    • I have installed and activated Twenty Twenty
    • I have installed the Site Kit plugin in incognito mode

    Unfortunately I still get an error message: “The page could not be found”

    The following URL is attempted:

    sassen.org/wordpress/wp-admin/?action=googlesitekit_proxy_setup&googlesitekit_code=sitekit-eGgkFN6ni5rZJcTN7cEGr&googlesitekit_site_code=4%2FwwGjnHW-HedEsHfsHud8_4SNwSWVc5XHaooiyHo1oI7dMy8I4zFMqS-1ktVDNUF2HSISxArsWC3gsGSlMF8CzM0&nonce=f541e29780

    I hope this information is helpful, Phil

    Plugin Support Renee Johnson

    (@reneesoffice)

    @philcomputing thanks so much for the info.

    1) To confirm the step in the setup process where the 404 happens, could you send us a screenshot of the page? Jumpshare is a service that allows you to upload and generate a link to share the image.

    2) Do you have any of SiteGround’s caching features enabled on the site at the server level? Could you try disabling those in your control panel area temporarily and reattempting setup?

    3) Do you have any security features enabled at the server-level?

    @reneesoffice,

    I am in contact with Siteground. There are no caching systems preventing the plugin to be installed, or security rules that are failing it.

    You can find the screenshot here: https://ibb.co/9w3hr7x

    • This reply was modified 4 months, 3 weeks ago by Philcomputing.

    An additional information that might be helpful: the page was originally set up under the subdomain dev.healthupyoutlife.com and was moved by an automatic process by Siteground to sassen.org

    Plugin Support James Osborne

    (@jamesosborne)

    @philcomputing I’m unable to check your site at present, it seems down.

    When you had Site Kit setup previously did you setup using the subdomain?

    @jamesosborne,

    thank you for your new attempt to help me on this.I am surprised to hear this. That really can’t be. sassen.org is up and running.

    This must have been a temporary problem.

    • This reply was modified 4 months, 3 weeks ago by Philcomputing.
    Plugin Support James Osborne

    (@jamesosborne)

    @philcomputing It may have been a temporary hiccup server side.

    Can you inform me whether you’ve setup Site Kit previously using the subdomain? If so inform me of the different variations of your domain here.

    @jamesosborne,

    I have used dev.healthupyourlife.com as a staging environment. After that I moved the WordPress instance to https://sassen.org/.

    In the properties overview in the Search Console I get the following information:

    http://www.sassen.org/

    3 hours ago = reconfirmation failed
    1 day ago = reconfirmation failed
    1 year ago = reconfirmation successful

    sassen.org
    2 years ago = Renewed confirmation successful

    It seems that the plugin tries to call the page via “http” and not via “https”.

    Greetings Phil

    @jamesosborne,

    strangely enough sassen.org is shown in the overview as a single domain without http: or “https: prefix. This seems to cause the error.

    Enclosed the screnshot of the overview: https://ibb.co/nrgFTc6

    • This reply was modified 4 months, 3 weeks ago by Philcomputing.
    Plugin Support Renee Johnson

    (@reneesoffice)

    @philcomputing thanks so much for the info!

    The sassen.org listing usually indicates the Search Console DNS verification method.

    I’m not sure if you configured this via your domain at some point, but it shouldn’t conflict with the setup process since your site address is https://sassen.org/.

    Site Kit supports this currently, but let’s check a few other items additionally:

    1) I actually noticed in this screen shot you provided that Site Kit is attempting to return back to your site dashboard via "https://sassen.org/wordpress..." which is probably why there is a 404.

    Did you at any point have the site or the WordPress (files) in a separate directory?

    It doesn’t look like you have this setup now, but let me know if this sounds familiar.

    @reneesoffice, thank you once again for your help.

    SiteGround had been informed. I post an updated on the process as soon as I receive a reply.

    Regards from Hamburg – Germany, Phil

Viewing 15 replies - 1 through 15 (of 21 total)
  • You must be logged in to reply to this topic.