• Resolved pisenberg


    Since I installed NGGallery 2.0.3 the singlepic command has stopped being recognized. I just see it in plain text in my posts with no attempt to resolve it to something else. E.g. it just appears like so:

    [sin­glepic id=455 w=450]

    I tried different settings (adding width and height and float) but it makes no difference. Previously working posts are also affected.


Viewing 15 replies - 1 through 15 (of 15 total)
  • I still have not been able to solve this problem. To be able to see my pictures, I am currently changing to the new shortcodes but I am experiencing a very strange behavior here, too.

    I edit my posts in the “text” editor – when I enter the shortcode just like this I get “Gallery not found. Please check your settings.”:

    [ngg_images image_ids='286' display_type='photocrati-nextgen_basic_singlepic']

    However, when I enter the shortcode like this, it works fine:
    <pre>[ngg_images image_ids='286' display_type='photocrati-nextgen_basic_singlepic']</pre>

    Is this to be expected behavior or is something very wrong with my settings or my installation? It seems quite counter-intuitive to me.

    I’ve got the same problem with the old [singlepic] shortcode, though it’s not consistent; some images appear, but others are replaced with “no images found” or (rarely) the shortcode text itself, and there’s no apparent rhyme or reason why some work and others don’t, including whether the shortcode falls within its own <div> tag, <p> tag, or even a <h3> (etc.). Oddly enough, depending on the location of the singlepic shortcode (just after a beginning <p> tag), the text within that specific paragraph becomes a different font, but goes back to normal when I revert to 1.9.13. I’ve been very briefly checking out each major update after 2.0, but so far the missing singlepic images (and peculiar text phenomenon) remain. Looking at the resulting page source, it appears that my leading paragraph tag gets removed, which may explain the different font. I don’t like leaving the site broken for long, so I don’t experiment for longer than 5-10 minutes at a time.

    I experimented a bit more and found that enclosing the singlepic shortcode (old style) within
    also works. I am currently wondering whether the problem only occurs for certain themes. I use Typominima: http://blogsessive.com/blogging-tools/typominima-typography-minimal-wordpress-theme/

    I am currently wondering whether the problem only occurs for certain themes

    Surely, or at least for a plugin, in other words it’s a local problem.
    Try to deactivate all plugins and with default theme, and you’ll see it directly. Then reactivate one by one to find the culprit.

    Plugin Author photocrati


    One of the single biggest issues with using shortcodes (and not necessarily just with NextGEN Gallery) is ensuring you do not have any “smart” quotes included around any of the parameter values.

    A simple way to make sure there are no “smart” quotes being used is to switch to the Text tab of the editor and < Save Draft >/< Update > the post/page after you have added the shortcode; then switch back to the Visual editor and carry on.

    Of course, this won’t make a difference if there is another plugin (or the theme) is creating a conflict with shortcodes.

    – Cais.

    I know why my singlepic codes aren’t showing for me. It’s the exclude checkboxes in the gallery. I had always used it so that I could show a few pictures within a page, then show the remaining ones down below in the gallery (with no duplicates, thanks to the exclude option). I don’t think exclude was ever intended to hide singlepic images, so I’m wondering: can the old functionality be restored?

    I had also had some issues with getting Thickbox to work in the updated plugin (made the code look weird, with class=\"thickbox\" rel=\"f96fbe39e410c00168f408311b98f103\" — note the added backslashes. In switching to the default 2013 theme and disabling, then re-enabling plugins one at a time, the thickbox problem seems to have gone away without being able to pinpoint the cause.

    Even with a working thickbox, unless I can keep singlepics visible while excluding the same image within a gallery, I may have to stick with the old plugin.

    @josh Yes I noticed too time ago that excluding images from manage gallery exclude them also working as single pics, but if you exclude them from the post editor via ATP they works as expected as single pics.

    As for the thickbox, when you have deactivated all others plugins and default theme is activated, and you active one by one, you have to empty the cache completely every time checking well so you can really see when the issue appear.

    Good idea about going through the plugins. wp-typography was the culprit for me: http://kingdesk.com/projects/wp-typography
    Now all is back to normal, yeah :-). Too bad about the plugin, though. I really liked it.

    …you have to empty the cache completely every time checking well so you can really see when the issue appear.

    Did that.

    if you exclude them from the post editor via ATP they works as expected as single pics.

    That’s some new functionality that I may have to play around with. My old method of insertion was made quick and easy by having Manage Gallery open in a separate Tab so I could grab a photo ID numbers on the fly and bulk exclude the singlepics. If it involves going so far as to replace all those instances individually by using the regular insertion method, that’s going to be a bit of a drag. And if at that point I need to revert back to the old version due to some unforeseen issue, well… I may just wait a while longer before converting everything.

    @josh you’re right, and I had already exposed this problem time ago in a topic of mine (which now I can’t trace). As said, I solved this problem using the exclude image function in the posts editor ATP panel, and obviously by removing the flag from all of them in manage gallery (I say, I also remove the field in those pages from visualization because I didn’t want to see it no more since right-now it’s useless!).
    Just like you, (in some cases) I don’t want duplicates in the gallery displayed below the article, but this requirement for me it’s not for every and few single pics, so they weren’t many.
    So if you have a lot of excluded single pics I understand very well your problem, but I couldn’t be aware of this when I warned you about this new thing.
    (And, btw, this was the pisenberg topic, with a different problem, so this topic could even be marked as resolved).
    But I can’t understand when you say about your old “quick” method of insertion, with two separate tabs open.
    OK for the remove-all-checks-and-do-them-again-in-the-editor hard work, as said was a problem for me too, but for the future you can grab single pics and exclude from gallery at once in the same page…

    But I can’t understand when you say about your old “quick” method of insertion, with two separate tabs open….but for the future you can grab single pics and exclude from gallery at once in the same page…

    With the Gallery open in the other tab, I have the entire list of relevant photos at my fingertips, just a matter of a quick tab switchover to see the ID numbers. No need to hunt for each image every time I want to include a singlepic; just a few keyboard taps for each instance. I suppose the new method is not a big deal for occasional new posts, but for fixing old ones, the workflow may be considerable slowed down.

    Plugin Author photocrati


    @pisenberg: Thanks for coming back and posting the solution. I’ve created an issue in our task list about wp-typography breaking NextGEN shortcodes so I can be sure we look at it, though I’m not sure exactly when that will be.

    @joshtt35, @tizz: to confirm, in the past, you could exclude images in the Manage Gallery tab and they would be excluded when displaying the whole gallery, but not when displaying singlepics. Now, if exclude is selected, they won’t show as singlepics either. So that behavior has changed. Tizz has provided a work around, but we still need to decide if/when we’re going to try and adjust this back to past behavior.

    Is that a correct summary?

    @joshtt35: From what I can see above, the Thickbox issue for you is resolved now, correct?

    @tizz: I just have to say you do an amazing job posting solutions, tips, and help for other NextGEN users. Kudos and thanks to you. I know we (the NextGEN team) always appreciate that, and obviously other users do as well. (Erick)

    AFAIK, the thickbox thing is no longer an issue. If it comes back, I’ll bring it up in a new thread, etc.

    Correct on the behavior summary for singlepics and galleries re: the exclude checkbox. I personally think the old behavior makes sense, that singlepic should override “exclude from gallery” invisibility for stand-alone images.

    Also a thanks to tizz for helping out. And thanks, folks at photocrati, for working hard at getting NextGen back up to speed. I’m sure its been a tough ride.

    The summary is correct for me too.
    I’m glad for Josh and others if you restore the option of excluding the images from Manage gallery as it was before – and use them anyway as s.p. of course – but please let also the new option to do so even from the ATP as now, don’t keep away this because otherwise I would do it all over again! 🙂

    Perhaps the ATP exclude option tizz mentioned should remotely enable the exclude checkbox that’s seen in the gallery; if I understand things correctly, that would then merge the new and old functionality together (so that exclude always means exclude from gallery, regardless of where the option was chosen). Maybe that would keep confusion minimal (and hopefully what I just suggested wouldn’t mess anyone up).

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Singlepic’ is closed to new replies.