WordPress.org

Support

Support » How-To and Troubleshooting » single.php showing all posts

single.php showing all posts

Viewing 11 replies - 1 through 11 (of 11 total)
  • Your single.php is not in your theme’s directory (or is renamed), so your theme is using index.php as a last resort. Put single.php back into your theme’s folder, or if it is missing, redownload your theme and upload that single.php.

    I took out Recent Posts from the left sidebar and it fixed it, but I want to have Recent Posts there! Why would this code I took out screw it up:

    <li class=”widget”>
    <h2>Recent Posts</h2>

    Uh oh, I just noticed that you are using only /%postname%/ as your permalink structure, which can cause problems.

    moved recent posts to the right sidebar and it works fine, i don’t know why i can’t have it on the left sidebar

    i am using that, but the same issue was occuring with the month/year option and default option as well. it’s a new site though, would you recommend i use some numeric data?

    Use this instead to show recent posts:

    <?php wp_get_archives('type=postbypost&limit=10'); ?>

    I’d recommend the Day and name permalink option.

    nice! it isn’t messing up single.php, but it is listing all posts twice in recent posts?

    It shouldn’t be. Is it nested in some sort of loop? All that query_posts and endwhile; endif; stuff should be removed from the that part of the sidebar.

    I just checked and it looks fine to me. Try refreshing your browser and/or emptying your browser cache.

    Not sure if anyone still needs to know but I’m pretty sure this will be an issue related to using multiple loops. You cant always just reuse the loop without either resetting it or assigning your loop queries to variables first. This should help:

    http://codex.wordpress.org/The_Loop

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘single.php showing all posts’ is closed to new replies.
Skip to toolbar