WordPress.org

Support

Support » How-To and Troubleshooting » single.php overun by 404

single.php overun by 404

  • When clicking on the title of a post instead of loading the single.php page it appears my 404.php is loaded instead.

    Any idea why this is happening? This is my loop on my index page.

    <div id="container"> <!-- THIS IS WHERE THE LOOP STARTS -->
    			<?php if(have_posts()) : ?><?php while(have_posts()) : the_post(); ?>
    
    				<div class="post" id="post-<?php the_ID(); ?>">
    					<h2><a href=”<?php the_permalink(); ?>”><?php the_title(); ?></a></h2>
    
    					<?php the_post_thumbnail(); ?>
    
    					<div class="content">
    						<?php the_content(); ?>
    
    						<p class="postmetadata">
    	<?php _e('Filed under:'); ?> <?php the_category(', ') ?> <?php _e('by'); ?> <?php  the_author(); ?><br />
    	<?php comments_popup_link('No Comments »', '1 Comment »', '% Comments »'); ?> <?php edit_post_link('Edit', ' | ', ''); ?>
    						</p>
    
    					</div> <!-- content -->
    
    				</div> <!-- post -->
    
    			<?php endwhile; ?>
    
    				<div class="navigation">
    					<?php posts_nav_link('','back','next'); ?>
    				</div>
    
    			<?php else: ?>
    				<div class="post">
    					<h2><?php _e('Not Found'); ?></h2>
    				</div>
    
    			<?php endif; ?>
    		</div> <!-- containter******* THIS IS WHERE THE LOOP ENDS-->

    I have looked all over and cant seem to find an answer. my permalink settings are set on default and i have tried all options.

Viewing 8 replies - 1 through 8 (of 8 total)
Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘single.php overun by 404’ is closed to new replies.