WordPress.org

Support

Support » Themes and Templates » single.php: How to show the full post?

single.php: How to show the full post?

  • I’m sure I’m missing something obvious, – but I couldn’t find the solution here or in the codex:
    Since I changed to 1.5/Kubrick, the individual entries are no longer shown.
    They are on the index page and in the archives, but the entry itself only is reduced to the title and the “This entry was posted on…” text.
    Looking at the single.php, I found that it calls “the_content” after the title.
    I even downloaded 1.5 again and uploaded the standard “single.php, but to no avail.
    When I delete the “Single.php”-file, the individual entries do not show up either.
    Any idea what I have been mising?

    Laurenz
    http://www.free-photos.org/

Viewing 10 replies - 1 through 10 (of 10 total)
  • Save your old archive.php (it is usually here: /wp-content/themes/default/archive.php). Upload a new archive.php and see if that works.

    Thanks, unfortunately, this does not work – the archive.php file doesn’t seem to have an impact on individual entries.
    To be honest, I didn’t expect it to considering that single.php is higher in the hierarchy of templates?!

    The only difference was that the standard archive.php does not show the images, – so I revived my own version.

    Laurenz

    anyone has an idea how to resolve this issue?

    Thanks!

    Did you modify anything in the core files? Are you using plugins? Is the single.php working in other themes?
    Can you post the code of your single.php here: http://pastebin.com/ and post back the URL

    No, I didn’t modify the core files – actually, I just carried out the latest upgrade.
    The only plugin I had activated is SearchHilite. Deactivating this did not change the appearance of my blog.
    I pasted single.php to http://pastebin.com/304287
    I’m not currently using another theme. Switching to WordPress Classic 1.5, gives a similar result: I’m being carried to a comments page.

    I has to be something with your other (core) files. I’d try to download and upload again the wp-include folder.
    (I’ve tried your code: it’s correct, works perfectly on my testbed.)

    I uploaded the includes folder again – no joy.
    I actually already did this for the latest upgrade…

    This works:
    http://www.free-photos.org/index.php?p=23

    So I’m guessing there’s a problem with rewrites. Please double-check the troubleshooting information here.

    This has come up before. When passing your permalink structure through index.php, use either %postname%, or %post_id%, but not both at the same time.

    Note this also works:

    http://www.free-photos.org/index.php/archives/abu-simbel-at-night/

    Thanks,

    it works! Really a pity that with this host I can’t use htaccess – they haven’t found a way of enabling it under Confixx so far…

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘single.php: How to show the full post?’ is closed to new replies.
Skip to toolbar