Support » Plugin: Beautiful taxonomy filters » Single taxonomies work only

  • Resolved cronyx

    (@cronyx)


    Hi – I have an issue with only being able to filter by one drop down at a time. All of the different drop downs work but only by themselves. As soon as I use 2 options, I get no results. I cannot see what I am doing wrong here. Using latest WP and Plug in.

    I made a very short video demonstrating this problem – https://www.dropbox.com/s/rnazur641pi5lhk/filters.mp4?dl=0

    Any help would be appreciated!

Viewing 4 replies - 1 through 4 (of 4 total)
  • I think it was an issue with post type – I made a few changes and it started working fine – I am not sure exactly which but this resolved itself!

    Plugin Author Jonathandejong

    (@jonathandejong)

    Hi @cronyx

    Hmm strange. But glad you “solved it” 🙂
    May I ask what changes you did?

    Hi,

    I had the same issue and i wanted to write to you about it and ask for help, but I figured it out.

    Let me explain the problem again.

    I installed version 2.3.1 and it worked fine..but the conditional dropdown values were refreshing very slow, sometimes a few seconds.

    Upgraded to 2.4.3 and conditional dropdown values stared working lightning fast, but I was only able to filter one taxonomy at a time, else I got a 404 page.

    The difference was in url:
    – v.2.3.1 url = posttype/taxonomy/term/taxonomy/term
    – v.2.4.3 url = /taxonomy/term/taxonomy/term

    I also have the CPT UI plugin installed.

    Fix:
    – go to CPT UI in your dashboard
    – click on Edit Post Types
    – scroll down to settings
    – and change value on “Has Archive” to True (default was False)

    This fixed my problem.

    Hope it helps someone.

    Thanks for the plugin, saved me a lot of work! 5 stars!

    @tilengigo – спасибо тебе добрый человек за совет!

    “Has Archive” to True (default was False)

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.