Support » Plugin: WP Data Access » Single Table sorting not working

  • Resolved websgt

    (@websgt)


    I have a single table. the index is on the column TERM (char (10)). If holds the term on an officer, example. 1964-1965, 1965-1966, etc.. However I set the default order/by in the data publisher (1,desc or 1,asc), but it has not affect on the sorting of the table.
    I am looking to sort this from the newest to the oldest. Since I entered the data from oldest to newest, that is the results I get. The page is live and the link is posted above.

    Thank you in advance for your assistance in this matter.

    • This topic was modified 4 months, 2 weeks ago by websgt.
    • This topic was modified 4 months, 2 weeks ago by websgt.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 16 through 19 (of 19 total)
  • Plugin Author Peter Schulz

    (@peterschulznl)

    Hi Steve,

    >>> I am adding a id column (rec_ID), I have it as mandatory, and key. How do I set it to auto-increment?

    Just add auto_increment right after your column definition.

    >>> I exported the records as a CSV , of course I did not realize that import only supports SQL…

    You can import CSV files as well. The import CSV button is right next to the Import data/Execute script(s) button. I think I need to change this… 🙈

    >>> Regardless, this change did not change the order of the records.

    I can see your default order by is defined correctly. I don’t understand why this is not working. Is it possible to give me temporary access to the server so I can have a look at the publication? You can use the contactform on the plugin website to contact me in private.

    What happens if you define the default order by on another column? Does that work?

    Best regards,
    Peter

    @websgt
    I’m sorry to hear that nothing appears to have worked for you. I hope Peter can help resolve the sort issue for you.

    I’m assuming that your datatable is located within your pre-installed WordPress database which gives you relatively limited access to it.

    Your website is hosted by DomainsByProxy which is a reseller for GoDaddy. The basic GoDaddy hosting account includes up 10 MySQL databases, so there is always the possibility for you to create your own database outside of WordPress. This would enable you to have much more control over the data and Peter’s Plugin would still work as it caters for ‘remote’ databases which reside on the same server as would be the case in this instance. This is the way I prefer to work.
    Just something for you to consider for the future.
    Regards,
    Richard

    Thread Starter websgt

    (@websgt)

    @rvwill48,

    Yes, I am hosted by Godaddy.com, DomainsByProxy is my private registration to keep my contact info private, I am retired law enforcement, and was active when all of my domains were created. If I recall, I have unlimited sites & databases. I still have my old databases from my old sites (MS SQL), but I don not wish to use the remote option.

    @peterschulznl,

    I dropped and rebuilt the tables multiple times. BTW, the auto_increment option is only available on the basic mode, its not in the drop down in advanced mode. I had to view one of your tutorials to figure out what I was missing.

    In the last import it missed 1 record in the middle of the list. I manually added it. When you view the web site, it is out of order at the end of the list.

    I will contact you via your plugin page to get you set up to take a first hand look. I have worked with MS-SQL, and MySQL a very long time ago, so I am not exactly a newbie, but I am not an expert either.

    Your time and help is welcomed and appreciated.

    Thanks,
    Steve

    Thread Starter websgt

    (@websgt)

    @peterschulznl ,

    Thank you for identifying the issue, and a temporary work around. Excellent support and plugin!

Viewing 4 replies - 16 through 19 (of 19 total)
  • You must be logged in to reply to this topic.