Support » Plugin: Sermon Manager » Single Sermon Page Image Error

  • Resolved jahrat

    (@jahrat)


    I have recently started having an error with the display of sermon images when I set a specific image for a sermon. If I use the series image for a sermon it shows on the Archive and individual sermon page. When I add a unique image for a sermon it does not show up and I see an error code “Failed to load: code 400”. If I go back and remove the unique image the series image will return.
    If I use an image that was uploaded before the update or one recently uploaded I get the same error.
    I disabled each override checkbox one at a time and checked the frontend each time. None of them affects the display of the image. The error code remains as above.
    Any suggestions?

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author wpforchurch

    (@wpforchurch)

    Hi, @jahrat I’m sorry for the issue, we just released a new version 2.16.3 to fix the issues with image display when using the shortcode. Please let us know if you still have an issue with our latest version. Thanks…

    jahrat

    (@jahrat)

    Hello @wpforchurch thank you for the quick update. I ran the update as requested. I am still not seeing the sermon image on either the Archive page or the single sermon page. The element involved (using Inspect tools in Chrome) is below.

    img alt=”Saved to Serve” data-src=”https://i0.wp.com/gmc-mca.org/wp-content/uploads/Saved-to-Serve.jpg?resize=604%2C270&ssl=1″ class=”wpfc-sermon-single-image-img lazyloaded smush-detected-img smush-image-2″ src=”https://i0.wp.com/gmc-mca.org/wp-content/uploads/Saved-to-Serve.jpg?resize=604%2C270&ssl=1″ – This is the single sermon page.

    div class=”wpfc-sermon-image-img” style=”background-image: url(https://i0.wp.com/gmc-mca.org/wp-content/uploads/Saved-to-Serve.jpg?resize=604%2C270&ssl=1)” – This is from the Archive page.

    The error code is the same.

    • This reply was modified 4 months ago by jahrat.
    • This reply was modified 4 months ago by jahrat.
    Plugin Author wpforchurch

    (@wpforchurch)

    @jahrat I can see the source of the image but for some reason, the remote data could not be fetched. I’m getting Error 0004 unable to load the image when I tried to open the URL of that image. Could please try to disable your image optimization and re-upload the image to your sermon or try to upload a new image file. If you still have an issue please email me here harold@wpforchurch.com thanks

    jahrat

    (@jahrat)

    Hello @wpforchurch I have tried disabling all image optimization and still have this problem. I also tried to load an image into a post and the same issue occurred so it appears this is not a Sermon Manager problem but more across my site.
    Will have to do some more checks and see.
    Thanks.

    jahrat

    (@jahrat)

    Hello @wpforchurch
    I uploaded a .png file and it worked just fine. I also used a .jpg image uploaded in 2019, March 2020, June 2020, August 25, 2020 and those also worked fine.
    After all my checks there seems to be an issue with two specific images that were uploaded for sermons that will not display anywhere. All other images I have tried in Sermon Manager work just fine.
    I guess I will just have to delete these and try to upload them again.
    Thanks for the interest and help you provided.
    Great job.

    jahrat

    (@jahrat)

    Images uploaded and replaced. Bug fixed.
    Thanks for your assistance @wpforchurch.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.