Support » Plugin: Estatik Real Estate Plugin » Single Property Page with shortcode

  • Resolved sbandura

    (@sbandura)


    Hello,

    i want to create my own single property page without the widget from estatik.
    I use for this the shortcode [es_property_field name=”xxxxx”] to display all relevasnt values.

    Is it possible to show the single property images with a shortcode inside the single property page?

    In the field builder i can create a field for images and other document types, but this field can not used by sliders per default?

    Thanks

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Estatik

    (@estatik)

    Hi there,

    There is no shortcode to display the gallery in our plugin. A code modification is required to show the gallery on the page. Do you have coding skills? If so, we can give you advice on modification.

    If the problem is only in the Estatik Request widget, then we can help you remove it from the page.

    In this case, please email us via the Contact Form>>.

    Thanks.

    Thread Starter sbandura

    (@sbandura)

    Hi,
    thanks for your answer.

    What do you mean with coding skills? Im not a professional WP developer but maybe i have to change just a few lines of code :D?

    Plugin Author Estatik

    (@estatik)

    Hi again,

    We think it’s worth a try.
    1. Create a child theme.
    This link may be useful to you – https://developer.wordpress.org/themes/advanced-topics/child-themes/

    2. Override the functions.php template in your child theme.

    3. Add the following code to functions.php.

    `function es_gallery_shortcode() {
    ob_start();
    do_action( ‘es_single_gallery’ );
    return ob_get_clean();
    }
    add_shortcode( ‘es_single_gallery’, ‘es_gallery_shortcode’ );`

    If done correctly, you can use the [es_single_gallery] shortcode for your needs on the listing page.

    Please, try it and let us know.
    Thanks.

    Thread Starter sbandura

    (@sbandura)

    Awesome it works!

    Unfortunately i can not view the picture in full width. I use Elementor and tried every single setting, but the pictures heigt/width are always the same.

    Additionally there are numbers under the pictures.

    Maybe you have another tip?

    On top of that i want to display the user name and contact fields of the account who publish a new property. At my website everyone can register and add new propertys. Is there any shortcode field for this?

    Thanks in Advance

    Plugin Author Estatik

    (@estatik)

    Hi again,

    We are glad that you successfully implement the code.

    Unfortunately i can not view the picture in full width. I use Elementor and tried every single setting, but the pictures heigt/width are always the same.

    You need to set your own image styles in child theme using after_setup_theme hook.
    Something like this:

    add_action( ‘after_setup_theme’, function() {
    $styles = array(
    ‘thumbnail’ => array( 100, 100, true ),
    ‘es-image-size-archive’ => array( 1024, 768, true ),
    ‘es-agent-size’ => array( 266, 350, true ),
    ‘es-pdf-featured’ => array( 385, 335, true ),
    ‘es-pdf-thumbnail’ => array( 160, 105, true ),
    );
    foreach ( $styles as $style => $args ) {
    add_image_size( $style, $args[0], $args[1], $args[2] );
    }
    }, 11 );`

    Additionally there are numbers under the pictures.

    Could you, please, share a screenshot?

    On top of that i want to display the user name and contact fields of the account who publish a new property. At my website everyone can register and add new propertys. Is there any shortcode field for this?

    This information is contained in the Agents section. You need to override the classes/pages/class-property-single-page.php in your child theme and change the order in which the sections are displayed on your single listing page or display the fields you need separately.
    Please note that agents feature is included in PRO/Premium version only.
    Thanks.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.