WordPress.org

Forums

single post now can not be updated or edited (21 posts)

  1. drkknght
    Member
    Posted 3 years ago #

    a single post in my blog can now no longer be updated. any attempts to update the post look like they've been successful, and everything appears to be happening correctly, but when the editing page reloads after the edit took place, none of the new content or edits appear.

    Here is the post in question:
    http://toonbarn.com/wordpress/wp-content/uploads/2011/03/ToonBarns-FREE-Nintendo-3DS-Giveaway.jpg

    is the thread simply too popular? too many comments? too much processing? have i made too many edits in the past and simply hit my "limit"?

    notes:
    - this is the ONLY thread this issue happens with
    - edits and revisions work fine on EVERY other post
    - only the "body" can't be updated: i can apparently add and remove tags
    - i've made numerous changes to this post before, without error

  2. tigtog
    Member
    Posted 3 years ago #

    That link is just to an image, not a post?

    is the thread simply too popular? too many comments? too much processing? have i made too many edits in the past and simply hit my "limit"?

    I doubt that any of those are the case. Have you recently added any new plugins?

  3. drkknght
    Member
    Posted 3 years ago #

    bah, sorry - here's the proper URL:
    http://toonbarn.com/2011/03/toonbarns-free-nintendo-3ds-giveaway/

    no new plugins. even did the "disable one-by-one" bit to see if that could work, but no dice there.

  4. drkknght
    Member
    Posted 3 years ago #

    incase this helps any... there's also existing revisions of the post in the little revisions window. however, i can't access any of those, either.

  5. esmi
    Forum Moderator
    Posted 3 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

  6. drkknght
    Member
    Posted 3 years ago #

    heya esmi

    tried the previous two, and just tried that third option. unfortunately, no dice :( still can't edit just this one post.

  7. esmi
    Forum Moderator
    Posted 3 years ago #

    It could be a server security configuration issue:
    http://wordpress.org/support/topic/cant-save-a-post-or-page-with-certain-text

  8. drkknght
    Member
    Posted 3 years ago #

    hmmm... that seems a bit beyond my brain limits :)

    ill see what i can dig into. thanks, esmi.

    just to note: i saw a comment on that other thread about actual post content. if this helps clarify even further, even if i try deleting all of the text in the post and saving an empty entry, or an entry with just a single random word like "baseball", i get the same "no change" result

  9. esmi
    Forum Moderator
    Posted 3 years ago #

    Try re-creating it as a new post and see what happens.

  10. drkknght
    Member
    Posted 3 years ago #

    heya esmi

    i could -- but the main sticking point with this particular thread is the comments (long story short, the comments are entrants to an ongoing contest). starting a new thread would disassociate the two, correct?

  11. esmi
    Forum Moderator
    Posted 3 years ago #

    Correct. Consider it an experiment initially.

  12. drkknght
    Member
    Posted 3 years ago #

    ok - testing post created:
    http://toonbarn.com/2011/03/toonbarns-free-nintendo-3ds-giveaway-2/

    i tried to make it as similar to the first as possible (same content, same date/time, same tags, etc.) and it edits / updates fine (note the "Nintendo 3000DS!" at the end of the first paragraph)

  13. esmi
    Forum Moderator
    Posted 3 years ago #

    OK - so that rules out a server security issue. Best guess right now is that there's been some minor damage to your database. Have you tried repairing it?

  14. drkknght
    Member
    Posted 3 years ago #

    i haven't tried, no. i do have the WP-DBManager plugin (http://lesterchan.net/portfolio/programming/php/) for what it's worth, which claims to offer a repairing feature. however, i'm always too afraid to do anything like that :)

  15. esmi
    Forum Moderator
    Posted 3 years ago #

    I wouldn't trust a plugin for this, to be honest. I'd want to carry it out myself using Phpmyadmin. Do you have any recent database backups from before this problem began?

  16. drkknght
    Member
    Posted 3 years ago #

    i unfortunately do not :-/

  17. esmi
    Forum Moderator
    Posted 3 years ago #

    Then I'm afraid there's very little I can suggest that will help.

  18. drkknght
    Member
    Posted 3 years ago #

    FWIW, this issue seems to be happening on at least one other post:
    http://toonbarn.com/2010/02/a-monster-in-paris/

    again, i don't get an error message of any type, the changes just don't "take."

    other posts do not seem to be affected by this issue, as i can edit them with ease

  19. drkknght
    Member
    Posted 3 years ago #

    even odder... from a series of tests i did on that new post, i AM able to make INCREDIBLY minor changes to the post content. for example, adding one letter at a time in each update, i was able to spell out "sou" (the first three of "source") before the system would accept no more changes.

    no idea if that adds any sherlockian clues :)

  20. drkknght
    Member
    Posted 3 years ago #

    also, as more "FWIW" type info incase this points anyone in a better direction, i can apparently change the title of the post, but not the URL slug. i also can't delete the post.

  21. drkknght
    Member
    Posted 3 years ago #

    even more FWIW, in this on-going, scooby-doo-like mystery :)

    regarding the original post in question, http://toonbarn.com/2011/03/toonbarns-free-nintendo-3ds-giveaway/, i can continue making very small, incremental edits. i can add, and/or delete, one character at a time, or as many as 5 characters at a time. i delete a letter, hit update, delete another, hit update, etc.

    the post is very temperamental about which changes it will accept, and which it will reject, returning me to an unedited post with no error message.

    again, this is only an issue on a select few posts: only two that i've found thus far out of over 3,000. still no idea why, however.

Topic Closed

This topic has been closed to new replies.

About this Topic