Support » Plugin: Eventbrite API » Single Event View – Page not found

  • Now everything works fine in my Mamp Pro localhost setup, where the URL is set the same as the live URL and so on.

    On the live site, when you click on a single event it goes to a page not found error. I’ve actually uploaded the same files and database to another host I have access to and it seems to work fine, so I’m thinking it’s an issue with Strato here in Germany seeing both the client hosting and my own personal hosting are with them.

    I’ve duplicated the template files and added them to my theme with the folder name ‘eventbrite’ and the template files inside it. Events are always showing on the eventbrite.index.php, just not single ones on the live site.

    I’ve done the following tests:

    – Disabled all plugins except Eventbrite API and Keyring with no luck.
    – Changed the theme to Twentyfifteen and used the plugin templates (not the theme).
    – Changed PHP version from 5.6 (currently running on that locally and live) to 7.0
    – Tested with language set to English and German
    – Saved Permalinks again

    If you have any idea, it’d be hugely appreciated. Happy to send through relevant link and rewrite rules.

    Thanks
    Matt

Viewing 9 replies - 1 through 9 (of 9 total)
  • Me again! 🙂

    In the end I figured out the hosting the client is on is still using a 32bit PHP build and this was causing the problems. I used the following patch https://gist.github.com/wvega/31a4bef3b1db1d048e1d61172b87711b to resolve my issue and then in the eventbrite api > inc > functions.php adapted this code to allow iFrames to work as well.

    $eventbrite_id = get_query_var( ‘eventbrite_id’ );

    $src = add_query_arg( array(
    ‘eid’ => $eventbrite_id,
    ‘ref’ => ‘etckt’,
    ), ‘//eventbrite.com/tickets-external’ );

    Hi @youngbloodr77,

    I have stumbled across your post after searching for solutions to exactly the same problem…. The problem is that this website is running on 64bit PHP. I am wondering if that is definitely what fixed it for you, or if you have any other suggestions that I can check on my install?

    If EventBrite could chime in that would be amazing. This issue is doing my head in! Same thing, so the multi events page works fine but as soon as you click on the link to the single event it comes back with “No results” (404). I just cannot get my head around how it “fakes” posts, and how to intercept these requests.

    Any assistance would be greatly appreciated.

    Kind Regards,
    Sam
    Advantage Media Group

    Hey Sam,

    It’s most definitely what fixed it for me. Did you try code like this to check the server bit version?

    <?php
    if( PHP_INT_MAX == 2147483647 ) {
    echo ’32bit’;
    }else{
    echo ’64bit’;
    }
    ?>

    You can also check to see whether it’s catching the Eventbrite ID here. Otherwise it could be rewrite issues apparently, that’s the only other info I could find when I was trying to solve the problem.

    Let me know how you get on.
    Matt

    Hi Matt,

    Yeah I had used some code to show it was 64 bit. I had hoped it was 32 so I’d have a solution!

    Ok so it doesn’t look like it is catching the ID, how is it meant to be doing that? with session/get variables? That’s where I am a bit lost, it’s like it doesn’t even run through that code at all.

    Sorry to bother! Thanks for pointing me in the right direction.

    Sam

    Hey Sam,

    I take it you have your permalinks set to postname? Is the event in a category? If so, you need to make sure you have a root page with the same name as the category for that to work and not give a 404. Any extra information on the structure may allow me to help a little more.

    Thanks
    Matt

    Hi Matt,

    I was able to resolve the issue. You definitely pointed me in the right direction, although one of those problems I ended up trying so many different things that I cannot identify which was the solution. It was definitely a problem with the category base settings, which is pretty frustrating!

    Thanks so much
    Sam

    Hey Sam,

    The categories situation definitely isn’t well documented. Good to hear you finished up finding a solution.

    Take care.
    Matt

    @Youngblood77,

    I went to your 32 bit workaround patch and that got me running. Thank you for that.

    I also copied and pasted your code into my inc/functions.php and it gave me a hard “NO”. I had to remove the plugin and start over. Is there a certain spot within the code that I should paste it to, or maybe try and replace something that’s already there?

    Side question – if we’re running an extremely old version of php (in the 5’s), would upgrading to 7 fix the 32/64 bit problem or is that something my hosting service (godaddy) has to change?

    Cheers!

    Hey there.

    I’m a little confused with the ‘got me running’ and then the ‘NO’ didn’t work comment.

    I created a file with the patch link above and then in my functions.php file I added the following require_once.

    require_once(‘eventbrite/eventbrite-32bit-workaround.php’);

    What PHP error is it giving you?

    In regards to the 32/64bit question… my understanding is that it has nothing to do with the PHP version, it’s more the server PHP bit settings. I’m unfortunately not a server wizz, so unable to expand on that question anymore.

    Thanks

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Single Event View – Page not found’ is closed to new replies.