Support » Plugin: Advance WP Query Search Filter » single checkbox verification doesn't work

  • I’m using some filters and it’s ok, I just have a problem when i use a single checkbox:
    I created a custom filed which is a checkbox with value “NEW”; i need it to flag a post with a particular feature and I want the serach form to search the posts flagged with it.

    I added a new “meta filed” , I chosed the “new” metakey, selected “IN” as compare operator, selected checkbox and wrote one single option in the “drop down option” (I wrote NEW).
    But the filter doesn’t work.

    Is it correct the process?
    tnx

    http://wordpress.org/plugins/advance-wp-query-search-filter/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author TC.K

    (@wp_dummy)

    Does your value “NEW” is a single value, not in an array form?
    Try click on the Generate value in the adding meta field pop up window, to see if it generate “NEW” or an serialized array. If it is serialized array, then you have to change your “new” field to make store as single value.

    this is what come out generating the value:

    | a:1:{i:0;s:7:”leggero”;}

    how i can change my “new” field to make store as single value?

    Plugin Author TC.K

    (@wp_dummy)

    How do you create the “new”field? If you using plugin to do this, then you should try directly using text field or radio button.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘single checkbox verification doesn't work’ is closed to new replies.