WordPress.org

Support

Support » Plugins and Hacks » Single checkbox defaults don't work

Single checkbox defaults don't work

  • I have a meta query that finds posts that do NOT have a checkbox checked (they are not checked by default). I make a new post and it clearly doesn’t have the checkbox checked before or after saving, but the meta query doesn’t find it until I check the checkbox, save, uncheck it, and save again.

    http://wordpress.org/extend/plugins/types/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hi toastyghost,

    Hope you are using latest version of WordPress and Types. Please share your meta query for replicating and tracking the issue.

    [ Signature moderated. ]

    I do have the latest of both. Here’s the query:

    query_posts(array(
    	'paged' => get_query_var('paged'),
    	'posts_per_page' => 5,
    	'post_type' => 'executive-searches',
    	'orderby' => 'date',
    	'order' => 'DESC',
    	'meta_query' => array(
    		array(
    			'key' => 'wpcf-display',
    			'value' => 1,
    			'compare' => '='
    		),
    		array(
    			'key' => 'wpcf-filled',
    			'value' => array(0,'',false,null),
    			'compare' => 'in'
    		)
    	)
    ));

    edit: sorry for backtick noob

    Hi toastyghost,

    There is a bug, we are debugging it. Please confirm are you using WPML plug-in ?

    [ Signature moderated. ]

    No I’m not. Our site is for a regional event, so no need to localize for different languages.

    Hi toastyghost,

    We will try to solve the issue in upcoming version of Types 1.3. Thank you for informing the bug. Please wait. We are expecting to release the new version in two weeks.

    [ Signature moderated. ]

    Thanks for the timely responses. I’ll be keeping an eye out for your releases. This is a great plugin!

    Thank you very much Toastyghost.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Single checkbox defaults don't work’ is closed to new replies.