Support » Plugin: Flexible Map » Since yesterday Flexible Map doesn’t show KML files on the maps

  • Resolved miquelpontes

    (@miquelpontesgmailcom)


    Hi,
    I’m running a wildlife observations website called OPK (http://opistobranquis.info/en). We have many species records with a distribution map for each one. Yesterday it was working flawlessly, but today it is not showing observations records on the maps.

    An example can be found here (http://opistobranquis.info/en/yIcEj).

    These observation records are loaded straight from KML files like this one (http://opistobranquis.info/wp-content/uploads/kms/tenellia-foliata.kmz) using the following code:

    [flexiblemap src=' . $url . ' kmlcache="5 minutes" hidezooming=false maptype=satellite zoom=1 hidepanning=false scrollwheel=false dblclickzoom=true width=100%]

    where $url holds the URL address of the KML file. Whatever the reason this is not working today, but it worked fine, without changes, yesterday. Any ideas?

    Thank you in advance for your superb plugin and for your time.

    • This topic was modified 5 years, 3 months ago by miquelpontes.
Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author webaware

    (@webaware)

    G’day Miquel,

    I can’t say why, but Google Maps doesn’t seem to want to load the map file from your server. I loaded it onto DropBox and it happily loaded it from there.

    [flexiblemap src="https://dl.dropboxusercontent.com/u/26305751/maps/tenellia-foliata.kmz" zoom=1 width="100%"]

    Do you have any security that might prevent Google Maps from loading the file from the uploads folder? I can’t see any restrictions from my end because I was able to download the file, but maybe you have a restriction on robots or something. Also, perhaps it’s just taking too long to download, so Google is aborting the download.

    If you can, load your files onto a fast server that Google can always access. Amazon S3 is a good bet, or a simple nginx server that can serve up static files quickly (even Cloudflare in front of your server would be faster than a slow server).

    cheers,
    Ross

    Thread Starter miquelpontes

    (@miquelpontesgmailcom)

    Hi Ross,
    You’re absolutely right. It was our site preventing some Google server from accessing our website to display the KML files.
    In order to help the security system in our website we have an IP exclusion list fed into .htaccess and for some reason the IP of a Google server was included in the last update (curious as we only insert IPs from widely known misbehaving servers), hence that server lost access.
    We reverted .htaccess to a previous version and the maps display just fine again.
    Thank you very much for your prompt response and accurate answer. Right on the spot !
    Cheers !

    • This reply was modified 5 years, 3 months ago by miquelpontes.
    Plugin Author webaware

    (@webaware)

    Aha!

    Hi, I have the same issue with my page that my kml won’t be loaded anymore.
    I tried it from my Webserver and from my Dropbox account.

    The page is http://www.minimalistic-backpack.de/about

    The kml files and embedded codes are following:

    [flexiblemap src=”https://www.dropbox.com/s/jesskijrvopw64a/Journey.kml?dl=0″ kmlcache=”6 minutes” width=”100%” height=”400px” scrollwheel=”true”]

     

    [flexiblemap src=”http://minimalistic-backpack.de/gpsdata/Journey.kml” kmlcache=”6 minutes” width=”100%” height=”400px” scrollwheel=”true”]

    Can you help me? The kml is crated by an android app which saves my position every hour and uploads it to the server. Cheers.

    Thread Starter miquelpontes

    (@miquelpontesgmailcom)

    @danielve01 what happens if you load that app-generated KML into a local Google Earth installed in your computer?

    I tried to download your KML and import it into my local Google Earth and it showed an error like:
    “Analysis error in line 2, column 3: not well-formed (invalid token)”

    Once you clear this format error, I bet your maps will show again. If the KML was autogenerated by an APP, perhaps reinstalling the app in your cell-phone could help.

    • This reply was modified 5 years, 2 months ago by miquelpontes.

    @miquelpontes. Thanks for your help, right now I’m traveling so I don’t have a computer with Google earth -.- I tried to open it with some kml viewer on Android and only ‘GPX Viewer’ was able to load the route without any issues.

    the map was working for the last 6 month and adds points to this file. My smartphone Texteditor shows for line 2:

    <Pl<Placemark><name>Town of 1770 ,QLD</name><Point><coordinates>151.8838917,-24.1611292,0.0</coordinates></Point></Placemark>

    Maybe the kml format is not right anymore that the GPS LOGGER creates?

    • This reply was modified 5 years, 2 months ago by danielve01.
    Plugin Author webaware

    (@webaware)

    G’day @danielve01,

    Your file isn’t valid KML (or XML). Here’s the first few Placemark elements, which as you can see, are corrupted.

    <Pl<Placemark><name>Town of 1770 ,QLD</name><Point><coordinates>151.8838917,-24.1611292,0.0</coordinates></Point></Placemark>
    <Pl<Placemark><name>Rainbow Beach, QLD</name><Point><coordinates>152.9873496,-25.9393534,0.0</coordinates></Point></Placemark>
    <Pl<Placemark><name>Noosa, QLD</name><Point><coordinates>153.0826496,-26.3924348,0.0</coordinates></Point></Placemark>
    <Pl<Placemark><name>Australia Zoo</name><Point><coordinates>152.96009991316186,-26.836087272557723,71.75382295871322</coordinates></Point></Placemark>
    <Pl<Placemark><name>Brisbane, QLD</name><Point><coordinates>153.0134241,-27.466906,0.0</coordinates></Point></Placemark>
    

    Also note: DropBox are going to stop allowing public access to files in the Public folder from mid-March. You should move any files you share from the Public folder to your website or another fixed-URL host.

    https://www.dropbox.com/help/16

    Finally: please start a new topic when you have a request, per the forum guidelines.

    cheers,
    Ross

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Since yesterday Flexible Map doesn’t show KML files on the maps’ is closed to new replies.