Support » Plugin: NextGEN Gallery - WordPress Gallery Plugin » Since update to 2.0.66.37 upload issues

  • Since the last update of nextgen galllery with WP4.1 I do have a upload isssue with permissions.
    I am uploading as an administrator and have be able to upload more images before Nextgen became 2.0.66.37
    The rights of wp-content/ en wp-content/gallery are set to 755
    The owner rights of the mentioned directories are correct
    The PHP memory is at 512M
    The WPcache is OFF
    I do can upload an image in the desired gallery, which can’t be saved, because after the upload has been completed, Nextgen says that I don’t have the permission to upload and have to verify my rights and whether I am an administrator.
    Lots of hours I wasted on this issue and could not find a solution, even at the internet.
    I do comply the requirement php 5.4 mysql 5.5 512M and on my resellerserver I have 59 hostings with some the same combination of wp4.1 and latest nextgen gallery and working.
    Disabling all plugins didn’t work either.
    It’s not a server issue, because other installs works fine.
    Furthermore that installs shows in the Gallery : Galleryname – >Settings
    a path and in this install it doesn’t.
    Rollbacks to 2.0.40 didn’t work and updates after that either
    In the database the records with the paths are
    wp-content/gallery/posters/ Directorie exist
    wp-content/gallery/slideshow/ Directorie exist

    So that’s why I am puzzling.
    Upgrading to Pro I was considering, but not when this kind of issues still exist.
    How to solve this issue ?

    https://wordpress.org/plugins/nextgen-gallery/

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author photocrati

    (@photocrati)

    @webitman – I would suggest trying the Reset Option under Gallery > Other Options … and also looking at the folder permissions specifically set for the WordPress installation’s root folder.

    Thanks!

    – Cais.

    @photocrati
    Well I did the reset earlier and now once again with no result.
    All plugins deactivated and no results.
    Having the correct permissions set, see the Filesecurity of the WP All in One Security systeem.
    Name File/Folder Permissions
    root directory /home/karaph/public_html/wp/ 0755
    wp-includes/ /home/karaph/public_html/wp/wp-includes 0755
    .htaccess /home/karaph/public_html/wp/.htaccess 0644
    wp-admin/index.php /home/karaph/public_html/wp/wp-admin/index.php 0644
    wp-admin/js/ /home/karaph/public_html/wp/wp-admin/js/ 0755
    wp-content/themes/ /home/karaph/public_html/wp/wp-content/themes 0755
    wp-content/plugins/ /home/karaph/public_html/wp/wp-content/plugins 0755
    wp-admin/ /home/karaph/public_html/wp/wp-admin 0755
    wp-content/ /home/karaph/public_html/wp/wp-content 0755
    wp-config.php /home/karaph/public_html/wp/wp-config.php 0644

    Plugin Author photocrati

    (@photocrati)

    @webitman – Are you using the same address for both the WordPress URL and the Site URL? Also, are they defined in your wp-config.php (by default they are not usually defined here)?

    – Cais.

    I have a similar problem

    @webitman – I would suggest trying the Reset Option under Gallery > Other Options … and also looking at the folder permissions specifically set for the WordPress installation’s root folder.

    I can create a new gallery if the wordpress root is set to 777, but not if that directory is not writeable by www-data, even if wp-content/gallery is writeable. I get

    Directory /var/www/html/wordpress is not writeable !
    Check this link, if you didn’t know how to set the permission : http://codex.wordpress.org/Changing_File_Permissions

    Does NextGen really require the wordpress root to be writeable by the apache user? IIRC this was not the case for previous versions, and it is very bad security practice (in my apache .conf files I disallow php execution in uploads and gallery directories).

    @photocrati I do totally agree with @jimhu.

    I am waiting for the update because I can’t figure it out.
    Nextgen Gallery doesn’t have to have that kind of security !
    Best regards
    Alfred

    Plugin Author photocrati

    (@photocrati)

    @jimhu & @webitman – The folder permission should not need to be 0777 … 0755 should be more than sufficient.

    At the moment I would suggest trying out latest beta version found here: http://nextgen-gallery.com/nextgen-gallery-latest-beta/

    If the problem persists afterward, please send us a Bug Report (http://nextgen-gallery.com/report-bug/).

    Thanks!

    – Cais.

    I was having this issue as well with the latest stable release, and decided to test with the latest beta. The issue still persists as described by @jimhu and @webitman. I’ve tested in Firefox and Chrome. I will go ahead and file a bug report.

    After trying the beta I got :
    1. Uploading don’t show anymore I don’t have the permissions, but shows 0 files uploaded. This is the same when I tried to avoid the message of no having permissions by reverse engineering.
    Certainly I can do the reverse engineering but will have to miss the updates.
    2. After resetting Nextgen Gallery
    I got
    “”
    Exception thrown

    not defined for ExtensibleObject”
    “”
    And Nextgen Gallery is dead……..
    I don’t think this is correct.

    Yet I deleted all of Nextgen Gallery, because it was blocking the whole website.
    Installed a fresh copy with a fresh database and the same effect.
    image upload zero and after that again :
    “”
    Exception thrown

    not defined for ExtensibleObject”
    “”
    Hanging the website again.
    Now I deleted all Nextgen Gallery again and now have the website running until there is a real and stable solution. I lost too much time with this item.

    I can’t try this anymore because I am be able to install Nextgen Gallery again. There will have to be a cleaning operation before installing.
    Is there a cleaning tool ?

    But may be this can work for all the ones who hasn’t deinstalled Nextgen Gallery.
    In the past I had some entry problems in WP and I fixed this in the database because it seemed to be wrong for the Administrator.
    Go to the TABLE wp_usermeta and look for your “wp_capabilities” and your “wp_user_level”. Where wp_ is your prefix for the TABLEs
    First make a copy of these TABLEs.

    “wp_capabilities” reset to :
    a:1:{s:13:”administrator”;s:1:”1″;}

    “wp_user_level” reset to
    10

    Best regards and good luck.

    Plugin Author photocrati

    (@photocrati)

    @webitman – You may be best off submitting a Bug Report (http://nextgen-gallery.com/report-bug … please reference this topic) to correct the “new” issues you are seeing on your site (which we are finding have possibly roots in permissions on the site/installation).

    Thanks!

    – Cais.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Since update to 2.0.66.37 upload issues’ is closed to new replies.