Support » Theme: GeneratePress » Since update to 1.3.48 getting editor-style.css loading error while editing post

  • Since the new update, I’m getting this error whenever editing a post:
    Failed to load content css: [site url]/wp-content/themes/generatepress/inc/css/editor-style.css

    I tried copying over the file with a new one I got from downloading the update manually, but that didn’t help.

    I am using a child theme, and have it enqueued with a function in my child’s function.php file. It was working fine before the update.

    • This topic was modified 2 years, 7 months ago by jamminjames.
Viewing 9 replies - 1 through 9 (of 9 total)
  • Theme Author Tom

    (@edge22)

    Hmm, strange. The file exists right here on WP.org (where the files are served from): https://themes.svn.wordpress.org/generatepress/1.3.48/inc/css/editor-style.css

    It may be a false error caused by a plugin.

    You can always try re-uploading all of the core theme files as something might have been changed on your end.

    Yes, it is strange. I deactivated all plugins, downloaded your new theme version and re-uploaded all the theme files, removed all my child files to be sure it was nothing to do with that, flushed the cache, and it’s still happening.

    I found another post about the same error in the WordPress TwentySeventeen theme here. However, none of their solutions seemed to apply. It does seem to be something to do with the new WP4.8 though.

    Would you mind having a look at the site and see if you can tell what’s going on?

    • This reply was modified 2 years, 7 months ago by jamminjames.
    Theme Author Tom

    (@edge22)

    Where exactly are you seeing the error?

    Whenever I go to /wp-admin/post-new.php to edit or create a post. It shows up in a pink box that floats near the top of the editing box.

    Theme Author Tom

    (@edge22)

    Hmm, well we have to look at something specific to your installation. We’re over 10,000 downloads since the latest update and this is the only report so far.

    What happens when you try to actually go to that URL in your browser?

    You mean just paste it in and go? Same thing. You have to be logged in, of course. The fact that other themes are having the problem seems to indicate something different in WordPress 4.8 that themes need to deal with (even though it doesn’t show up on every installation), don’t you think?

    I use an Nginx server, PHP 7.1 — don’t know if that matters.

    • This reply was modified 2 years, 7 months ago by jamminjames.
    Theme Author Tom

    (@edge22)

    You shouldn’t have to be logged in.

    So when you type in [site url]/wp-content/themes/generatepress/inc/css/editor-style.css into your browser and go, the file loads?

    GP doesn’t have any of the same issues as that topic – no @imports or other URLs.

    I get 403 Forbidden. I tried changing to the twentytwelve theme and going to the same file, and it did not give a 403. I checked the ownership and chmod of the files & directories of generatepress and they were different, so I corrected that, but I’m still getting the 403. Also turned off cache, but that made no difference.

    Theme Author Tom

    (@edge22)

    That’s typically a server issue then. Have you reported it to your hosting? If not, they might be able to spot the issue.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Since update to 1.3.48 getting editor-style.css loading error while editing post’ is closed to new replies.