Support » Plugin: HD Quiz » Since update… No results and no scrolling after submitting for scoring now!

  • Resolved nationaltradesman

    (@nationaltradesman)


    So a couple weeks back I had an issue with the quiz results not scrolling to the top. At that time you gave me some code to place into plugin which I done and it was working fine.

    But since I have updated:
    1. After submitting for results, the score is now not shown at all.
    2. Nor does it scroll.
    3. Correct answer info is still displayed however.

    I was happy for this update because I thought my previous problem with scrolling to top would be permanently fixed.

    Thanks for your timely help
    NT

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Harmonic Design

    (@harmonic_design)

    Are you using some kind of page caching? I just took a look and your site is not loading the new js file.

    Example: Your site is loading: https://nationaltradesman.com/wp-content/plugins/hd-quiz/includes/js/hdq_script.js?ver=1.0

    That shows the OLD cached JS file. If you remove the ?ver=1.0 at the end of the URL, then it correctly shows the new updated file.

    Because of this, I am 99.9% sure that this is an issue with Page Caching on your site.

    It looks like you are using “Endurance Page Cache” so the issue actually lies with the way that they are setting the cache timeout on your site. They probably have a simple “clear cache” button/option, and using this will fix the issue for you.

    Plugin Author Harmonic Design

    (@harmonic_design)

    UPDATE: Just did a quick search and it looks like Endurance Page Cache is some sort of automated caching solution from BlueHost. So if you cannot find a way to clear your site cache, you’ll need to contact Blue Host.

    Yeah… Im such a layman with this stuff..
    What Ive found given your info in my settings under “Endurance Cache” there are several options for “Cache Level”:

    1. Off (Level 0) …This is what it is set at.
    2. Assets Only (Level 1)
    3. Normal (Level 2)
    4. Advanced (Level 3)
    5. Aggressive (Level 4)

    I know this may out of the scope of your support/assistance but can you advice on this at all?

    Thanks NT

    Plugin Author Harmonic Design

    (@harmonic_design)

    I wish I could better direct you, but I do not use Blue Host myself, so I am unfamiliar with their caching solution settings.

    The first thing to do is to see if there is an option to “clear” or “delete” cache. This will delete all previously cached assets and force the plugin to rebuild them.

    Another option is to just disable Endurance Cache altogether. It’s been my experience that these types of plugins from web hosts are just terribile. I’d recommend replacing it with a plugin called WP Fastest Cache – I’ve never had an issue with that plugin before and even the free version makes a HUGE difference to page load times.

    Okay thanks again…

    I called Bluehost. They said they did a server side clearing and to wait 30 minutes.

    Two hours later still same problem so I called again. They said they did a server side clearing again and now it seems to be functioning.

    ???

    Yeah I dont get it and will have to try to educate myself on all this and look into your advise above.

    As always, great plugin and great support.

    Thanks for the time and patience.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.