Support » Plugin: Imagify – WebP & Image Compression and Optimization » Since update getting PHP fatal error

  • Resolved RobWord

    (@robword)


    Since the last update this has been appearing my my error logs.

    Fatal error: Uncaught ArgumentCountError: Too few arguments to function SucomUpdate::maybe_update_wpua(), 1 passed in /wp-includes/class-wp-hook.php on line 286 and exactly 2 expected in /wp-content/plugins/wpsso-um/lib/com/update.php:532
    Stack Trace
    
    1.	
    SucomUpdate->maybe_update_wpua('WordPress/5.2.2...')
    /wp-includes/class-wp-hook.php:286
    2.	
    WP_Hook->apply_filters('WordPress/5.2.2...', Array)
    /wp-includes/plugin.php:208
    3.	
    apply_filters('http_headers_us...', 'WordPress/5.2.2...')
    /wp-content/plugins/imagify/inc/classes/class-imagify.php:512
    4.	
    Imagify->curl_http_call('https://app.ima...', Array)
    /wp-content/plugins/imagify/inc/classes/class-imagify.php:415
    5.	
    Imagify->http_call('upload/', Array)
    /wp-content/plugins/imagify/inc/classes/class-imagify.php:290
    6.	
    /var/www/v in /var/www/vhosts/robsnow.eu/httpdocs/wp-content/plugins/wpsso-um/lib/com/update.php on line 532

    Anyway it can get fixed?

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • I also just tried the plugin and it doesn’t do anything. The wheels just spin and it doesn’t optimise any images. I left it for over 5 mins and it didn’t start not even one image, and I am at 95% optimised.

    FYI, since WordPress v5.1.0, that filter takes two arguments – Imagify is passing only one:

    imagify/inc/classes/class-imagify.php:512: $user_agent = apply_filters( ‘http_headers_useragent’, ‘WordPress/’ . get_bloginfo( ‘version’ ) . ‘; ‘ . get_bloginfo( ‘url’ ) );

    js.

    OK, but it has still stopped the plugin working 🙂

    Plugin Author WP Media

    (@wp_media)

    Hello @robword

    Thanks for providing this and sorry to hear about the issue.

    We have taken a closer look and we need to make a change in the plugin in order to fix the issue.

    We will do our best to fix it as soon as possible, so it will be fixed in the next version of Imagify.

    Best Regards

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.