WordPress.org

Forums

Since update, can't edit images (6 posts)

  1. rwilki
    Member
    Posted 2 years ago #

    Just updated one of my sites to 3.5 but now I'm getting this error whenever editing an image in my media library. Any ideas? Worked fine in 3.4.2

    "Could not load the preview image. Please reload the page and try again."

    Thanks,
    Bob

  2. esmi
    Forum Moderator
    Posted 2 years ago #

  3. rwilki
    Member
    Posted 2 years ago #

    Thanks Esmi. Just reviewed it. I think I found the culprit but not how to fix it.

    Failed to load resource: the server responded with a status of 403 (Forbidden) http://mysite.com/wp-admin/admin-ajax.php?action=imgedit-preview&_ajax_nonce=a0285ca213&postid=1046&history=%5B%7B%......
    Failed to load resource: the server responded with a status of 403 (Forbidden) http://mysite.com/wp-admin/admin-ajax.php?action=imgedit-preview&_ajax_nonce=a0285ca213&postid=1046&history=%5B%7B%......

    Any ideas?

  4. esmi
    Forum Moderator
    Posted 2 years ago #

    Check that anti-hotlinking isn't enabled in your hosting account. If it is, try disabling it.

  5. rwilki
    Member
    Posted 2 years ago #

    Actually Esmi, it looks like it's a plugin from perishable press. I don't see the problem but it's that one...

  6. johnyfive
    Member
    Posted 2 years ago #

    I think that problem is in sending headers before returning picture by ajax into browser. This is possible when in function.php or in some plugins exists empty lines between php closing and open tags ?> \n <?php or after closing tag ?> \n\n\n....
    So check your function.php file or your active plugins files that they have empty lines after php closing tag on the end of file.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.