Support » Plugin: AdRotate Banner Manager » Since last update, ads not showing, only code

  • Resolved jamminjames

    (@jamminjames)


    Since updating today to Adrotate 3.14.2, the ads are no longer showing, only some code where the ads should be. Seems like the database update your plugin always does (why is that, anyway?), corrupted it.

    The widgets are still there, and still have the same info in them.

    Please help!

    https://wordpress.org/plugins/adrotate/

Viewing 15 replies - 1 through 15 (of 29 total)
  • same issue – wrong echo code Many thanks

    False alarm, sorry … turned out to be some errant coding in the child functions file.

    can you give me some more hints regarding errant coding?

    I am having the exact same problem jamminjames how did you solve this?

    I am having the exact same issue myself and the code that is being render is echo adrotate_ad(4, true, 0, 0); or like this echo adrotate_ad(12, true, 0, 0); echo adrotate_ad(7, true, 0, 0);

    I also have the problem. It’s just displaying the code, NOT the content.
    HELP! Arnans???

    Same problem here. Please help!

    Was this resolved with you guys? The topic has been marked as resolved, but my issue still stands…

    It’s NOT resolved.

    I got around it by re-installing the previous version 3.14.1
    https://downloads.wordpress.org/plugin/adrotate.3.14.1.zip

    Use “Easy Plugin and Theme updates” plugin, and you can install over the top of 3.14.2

    Unfortunately, I had “auto-update” switched on via jetpack, and it’s killed ALL adverts on ALL my sites. 🙁 NOT IMPRESSED. 8 sites in all. And this isn’t the first time an adrotate update has screwed things up.

    ** The plugin 3.14.2 is fine UNTIL you hit the big green “UPGRADE NOW” button. So Don’t click it! **

    Alright people, I went ahead and visited the other forum for this plugin as the author has pointed out that he does not visit here often, and as a respond to the same question here, he wrote this: (I’m copy -pasting it)

    “That’s to do with the AdRotate caching setting.
    If you don’t have W3 Total Cache installed, disable caching support in AdRotate Settings.
    If you do have that plugin, clear the cache.

    Also make sure there is no warning about W3TC_DYNAMIC_SECURITY in AdRotate settings > Misc. If there is, follow the instruction there.”

    I will try to see if it works, good luck!

    q292u, Thanks for the link to the previous version. If the above does not work, we could at least go back to the way things were.

    Meri Zaha, I tried doing what you said, but still doesn’t work. Do I really need install the previous version?

    Okay, I was having multiple issues, and I was wrong when I said the adrotate issue cleared up when I fixed some other code on my site.

    I have W3TC and did what Meri said, however, it didn’t clear up. So, I disabled the cache and unchecked the cache setting in adrotate, and cleared the browser cache and looked again, and it was alright.

    Then I re-activated W3TC and cleared all its caches, then re-checked the cache setting in adrotate, and it all appears to be okay again.

    jamminjames, thank you man! It works!

Viewing 15 replies - 1 through 15 (of 29 total)
  • The topic ‘Since last update, ads not showing, only code’ is closed to new replies.