Support » Plugin: PDF Invoices & Packing Slips for WooCommerce » Since ive installed the plugin my url changed

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Contributor Ewout


    Hi! This is not a very good sign – it is certainly not caused by the PDF invoice plugin (free or pro), as it does not change anything in the URL settings.

    Turn off plugins one by one to find out which one is causing the url extension. Your site may also have been compromised/hacked, I advise you to change your passwords just in case.

    Good luck!



    Same thing has happened to me, and I’m certain it’s Woocommerce because I just have Woocommerce plugin activated ONLY. I deactivated ALL plugins, purged the cache, URL is back to normal, turned on Woocommerce ONLY, and the bad URL reappears. So I know this is an issue with Woocommerce. Maybe it’s conflicting with my theme, but I really like the theme, and the developer programmed it to work with Woocommerce, so it should work with the theme. I’ve already contacted the developer of the theme, and she said something about permalinks which I checked and they look fine to me.

    WooCommerce added this string at the end of my URL on ALL pages: ?v=25ef4c8004c3

    I really want to use Woocommerce on my site.



    Ah! I have the solution!

    If you have a look at our configuring settings documentation, you’ll see this under Default Customer Address

    Geolocate with page caching support is the same as above, but does the geolocation via Ajax. You may notice your website URLs have a ?v=xxxxx appended to them. This is normal to prevent static caching of prices.

    Can you check this setting? This won’t affect your page ranking since this is done on the customers computer.

    Hope this helps others!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Since ive installed the plugin my url changed’ is closed to new replies.