WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Since installing new version of wordpress, can’t access database?

[Resolved] Since installing new version of wordpress, can’t access database?

  • Hi there,

    When I first installed version 2.7 nothing went wrong but now, one day later, everything I click on generates the following error:

    Not Found
    The requested URL /wp/2008/12/28/90s-mainstream-mondays-4/ was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    Any ideas? The site in question is at http://www.thelaf.net/wp/

    where as another installation of wordpress accessing a seperate database seems to be working fine: http://www.thelaf.net/97/

    Thanks!
    belated happy holidays
    -Jesse

Viewing 11 replies - 1 through 11 (of 11 total)
  • how do i check which database it’s using? like if one is called tierzero_wp and one is called tierzero_new how can i check which one it’s trying to access??

    i did a database check on both through cPanel and they seem fine

    Look in the config.php file.

    I have the same problem.

    Directly prior to this, I deleted everything in FTP except wp-content, uploaded all WordPress 2.7 files, and put my old wp-config.php back in.

    Now posts and pages get 404 Not Found, but if I log in, all the data’s still there. Where did I screw up?

    Deactivate all plugins and switch to the default theme. If that fixes the problem, then you can start adding back plugins and changing themes…I would just do it one by one to see if one of them is causing the problem.

    thanks for the suggestion but that didn’t fix my problem.

    any luck danielkwan?

    Did you somehow change the naming structure of your posts? Or changed the post dates around?

    i played with those naming structures to try to fix it but it didn’t work. i don’t think it has anything to do with dates because even a link like http://www.thelaf.net/wp/category/art/ doesn’t work either

    just to test it out i added a random folder and an index.htm file to see whether that was accessible….

    http://www.thelaf.net/wp/whatever/

    and it works

    i tried re-installing 2.7 and that didn’t help… should i roll back to the last version??? my blog has been down for a couple days now it’s really not a good look

    i fixed it. i had somehow lost my .htaccess file so i coped it from thelaf.net/97/ changed all instanced of /97/ to /wp/ and it works now

    Fixed now. I had to go into Permalink Settings. The correct one was already selected (“Day and name”) but I hit “Save Changes” anyway, and now things are back to normal.

    hey when this all happened my blog went down and people could view the contents of my server….. so i had to change my main .htaccess file but now i need to change it back

    RewriteEngine On
    Options -Indexes
    RewriteBase /
    RewriteCond %{HTTP_REFERER} .*google.* [OR]
    RewriteCond %{HTTP_REFERER} .*ask.* [OR]
    RewriteCond %{HTTP_REFERER} .*yahoo.* [OR]
    ….

    i changed options to “options -indexes” and saved what it originall was to a .txt document but now i cant find it. does anyone know what “options” might have been set to originally?

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Resolved] Since installing new version of wordpress, can’t access database?’ is closed to new replies.