Support » Theme: Sinatra » Sinatra Theme

  • Resolved Jules Play

    (@jules-play)


    This page is not the way I want it to look. I don’t want the lines above and below the main menu. I don’t want the row filled with white after the last row before the main menu. Also, I can’t get the footer font to be smaller and white. What am i missing? Is there a theme that would work better for me? I have this in my Additional CSS: #sinatra-footer .sinatra-footer-column {
    padding-top: 30px;
    padding-bottom: 30px;
    }

    #panel-99-0-0-0 p {
    margin-top: 0;
    }

    Any help would be truly appreciated. Stay safe!

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • @jules-play,

    All of those options are available in the Customizer.

    1) Header borders:
    – Go to Appearance » Customize » Header » Design Options » Border and set the “Bottom” value to 0. Screenshot.

    – Then, go to Appearance » Customize » Header » Main Navigation » Design Options » Border and set the “Top” value to 0.

    2) Margin around logo
    – Your logo image has some whitespace around the actual graphic, but you also have 30px bottom margin for your logo.

    – To change that go to Appearance » Customize » Logos & Site Title » Logo Margin and set the “Bottom” value to 0. You can also use negative values, like “-10”.

    3) SiteOrigin builder that you are using is overriding Footer styles defined in the Customizer. In order to override SiteOrigin builder styles for the footer, you can add the following CSS into the “Additional CSS” in the Customizer:

    #colophon p {
      color: #FFF;
      font-size: 16px;
    }

    Let me know if you need more help with these.

    Thanks!

    If you are already using a page builder, you may also want to try using “Sinatra Fullwidth” template for your page.

    Edit the page and look for “Page Attributes” on right side. Under “Page Attributes” look for “Template” and change from “Default template” to “Sinatra Fullwidth”.

    Screenshot.

    Sinatra Fullwidth template will get rid of all spacings around the main content and it will give you a “blank canvas” for the content area to work with.

    Thread Starter Jules Play

    (@jules-play)

    Awesome! Thank you both so much. I thought I had tried every option in Appearance/Customize. I had not. Thank you also for taking the time to send screen shots. Your time is greatly appreciated. Thank You! Stay safe.

    Theme Author sinatrateam

    (@sinatrateam)

    Resolving this issue.

    this is about the column width setting in the sinatra theme
    1.) will it be possible to add addtional colum then the pre set footer column and width configuration

    2.) will it be possible to change the default setting column width with addtional CSS code

    brankoconjic

    (@brankoconjic)

    Hey @maxma,

    You’d have to extend theme code in order to add another column in the footer. Follow these steps:

    1) Use a child theme or install Code Snippets plugin.

    2) Add the following code to add the additional column in the footer:

    add_filter('sinatra_footer_column_classes', 'sinatra_custom_footer_widgets_col');
    function sinatra_custom_footer_widgets_col($classes) {
    	$classes['layout-1'] = array(
    		'col-xs-12 col-sm-6 stretch-xs col-md',
    		'col-xs-12 col-sm-6 stretch-xs col-md',
    		'col-xs-12 col-sm-6 stretch-xs col-md',
    		'col-xs-12 col-sm-6 stretch-xs col-md',
    		'col-xs-12 col-sm-6 stretch-xs col-md',
    	);
    	
    	return $classes;
    }
    
    add_action( 'widgets_init', 'sinatra_custom_footer_widgets' );
    function sinatra_custom_footer_widgets() {
    	register_sidebar(
    		array(
    			'name'          => esc_html__( 'Footer 5', 'sinatra' ),
    			'id'            => 'sinatra-footer-5',
    			'description'   => esc_html__( 'Widgets in this area are displayed in the fifth footer column.', 'sinatra' ),
    			'before_widget' => '<div id="%1$s" class="si-footer-widget si-widget si-entry widget %2$s clr">',
    			'after_widget'  => '</div>',
    			'before_title'  => '<h4 class="widget-title">',
    			'after_title'   => '</h4>',
    		)
    	);
    }

    Make sure you have selected “Footer Layout 1” (in the Customizer » Layout Settings » Footer » Main Footer » Column Layout).

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.