Support » Plugin: Simply Static » Simply Static insists on ftp access upon adding the plugin

  • Resolved georgschwarz

    (@georgschwarz)


    I’ve installed a fresh local WordPress installation on a Linux system. Now via the admin web interface I tried to add Simply Static as a plugin. After selecting ‘Install Now’ on Simply Static the install dialogue prompts me for hostname, ftp user and ftp password. Below there’s a single radio button with ‘ftp’ as a connection type; no other options are there to choose from. when I hit ‘next’ Simply Static tries to verify the data provided, and since I don’t have (nor need) ftp access this fails and I cannot proceed with the installation process.
    I tried it with both a WordPress 5.6.2 as well as a 5.7 installation; same phenomenon in both cases. Browsers don’t seem to make a difference.
    What’s the trick for getting Simply Static added to one’s WordPress installation without providing working ftp access?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author patrickposner

    (@patrickposner)

    Hey @georgschwarz,

    that’s not really specific to Simply Static, right?
    Have you tried installing another plugin? The problem should be the same here.

    You have to modify the file permissions for WordPress (there are a lot of good tutorials out there) to prevent the need of adding the FTP credentials.

    Best regards,
    Patrick

    Thread Starter georgschwarz

    (@georgschwarz)

    Thanks for your kind clarification. You’re of course absolutely right. I was confused because it did not occur to me that WordPress could not write to the local installation (or at least it kept thinking it couldn’t).
    It turned out that although http should have the necessary permissions (which I had modified beforehand), the check nonetheless fails, and so WordPress resorts to ftp as the sole installation method. Explicitly specifying in the WordPress config file that direct installation is possible solved the problem, and direct installation succeeded with no problems (cf. eg. http://kb.rolet.com/install-wordpress-plugins-without-ftp-access/).

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.