Support » Plugins and Hacks » Simply Poll not displaying resultss

Simply Poll not displaying resultss

  • HI,

    I’ve got Simply Poll installed, it displays the poll questions. When you vote on a question and click submit nothing is shown, just white space.

    Viewing the source shows that the code is there but not visible. Refreshing the page, brings the voting choices back but once you click on a choice, the selections fade out, and only white space remains, no results show up.

    WordPress v3.1.4
    PHP v5.1.4



Viewing 15 replies - 1 through 15 (of 45 total)
  • Plugin Author WolfieZero


    I’ve tried to replicated the issue on my local machine but to no avail. The issues appears to be something with the Javascript (jQuery).

    I think it’s hitting the $.ajax() function and failing there; I’m not sure if it’s the call back it will have an issue with or the returned results. Are you able to show the page where you have installed SP that I can have access too?

    (I will put a note in to add some debugging features in a future update)

    I appologize, I failed to also mention that when installing the plugin, I received this error.

    “The plugin generated 506 characters of unexpected output during activation. If you notice “headers already sent” messages, problems with syndication feeds or other issues, try deactivating or removing this plugin.”

    The site can be viewed here: http://tinyurl.com/7t8uc2o

    Plugin Author WolfieZero


    Ah, you are missing a file for some reason. The error the console is giving me is

    POST http://www.shaunnelson.com/wp-content/plugins/simply-poll/page/user/poll-submit.php 404 (Not Found)

    Try uninstalling and installing the plugin again. If that doesn’t work then try and download the plugin and manually upload it to your plugins folder and see if that works.

    If none of that works then I might need to specifically check the plugin against the WP and PHP versions you specified.

    Strange, I ftp’d into the directory and the file is there. I’ve uninstalled and re-installed the plugin. The plugin was installed by ftp’ing the folder to the plugins directory then activating it via the WP control panel. Funky path issue prehaps with the version of PHP I’m using?

    The URL in the POST is missing the /wordpress_31/ directory. It should read like this below.


    Is there something in the poll code that assumes the wordpress installation is at root level?

    Plugin Author WolfieZero


    Ah, that will be it then! It’s not picking up the real full path. I have presumed the WP install is always root.

    I won’t be able to do it today but I’ll try and push an update tomorrow to tackle that very issue.

    Good spot! I use a mu installation as well, but my sites are setup to run via a sub-domain so I’m always working from root.

    I just changed the path in the config.php file but it still isn’t working.


    Hmmm I’m determined to figure this out cause I like the simplicity of the poll.

    Plugin Author WolfieZero


    haha goes in hand with the name.

    It’s still the wrong URL according to console. You’ll eliminate a few steps in testing by keeping the console open as chances are any issues are Javascript based.

    What console are you referring to, a Firefox console or a WordPress console?

    Plugin Author WolfieZero


    I use Chrome, which has one built in, but Firefox you’ll need the Firebug add on to get the console.

    I am running one for Firefox, I see the path is correct now in my console.

    Still not coming up with results after submitting the vote.

    [11:43:44.975] Use of getAttributeNode() is deprecated. Use getAttribute() instead. @ http://www.shaunnelson.com/wordpress_31/
    [11:43:45.003] Use of attributes’ nodeValue attribute is deprecated. Use value instead. @ http://www.shaunnelson.com/wordpress_31/
    [11:43:45.610] POST http://www.shaunnelson.com/wordpress_31/wp-content/plugins/simply-poll/page/user/poll-submit.php [HTTP/1.1 200 OK 281ms]
    [11:43:45.807] POST http://www.shaunnelson.com/wordpress_31/ [HTTP/1.1 200 OK 547ms]

    It seems to point to the correct path now.

    Plugin Author WolfieZero


    Hmm, to better check something I’ll need you to add a line to the code.

    Go to /simply-poll/script/simplypoll.js and on line 48 can you add console.log(data); and on line 56 add console.log(html); then we can see if we are getting an AJAX response and what’s coming back.

    Ok, give it a try.

    Plugin Author WolfieZero


    Odd, the script isn’t sending any data back from the first ajax request. I think I know what the issue is and it’s to do with the subdomain.

    I’m going to be offline for the rest of the night, but I’ll setup a local environment tomorrow and get that issue replicated and thus fix it. I can let you know the fixes involved as well if you like?

    You can take those console.log() functions out now. Thanks for being helpful trying to solve this issue; I will try and get the fix up tomorrow.

    Thank you for your help!! Regardless of the outcome, I do appreciate it!

    I realize your offline but I’m still plugging away. Thus far I’ve been able to get the poll to work but only by doing the following.

    modifying wproot.php to include my subdirectory

    $wpRoot = $_SERVER[‘DOCUMENT_ROOT’].’/wordpress_31′;

    and changing the config.php lines to the following

    define(‘SP_URL’, ‘http://’.$_SERVER[‘HTTP_HOST’].’/wordpress_31/wp-content/plugins/simply-poll/’);
    define(‘SP_URI’, $_SERVER[‘DOCUMENT_ROOT’].’/wordpress_31/wp-content/plugins/simply-poll/’);

    You can vote, but the results do not show UNLESS you refresh the browser, then you can see the results.

    A step in the right direction though I think!

Viewing 15 replies - 1 through 15 (of 45 total)
  • The topic ‘Simply Poll not displaying resultss’ is closed to new replies.