Support » Plugin: WebP Express » Simply not working and no idea why

  • Resolved miculgigant

    (@miculgigant)


    Hello,

    I have installed the plugin and chose:

    CDN Friendly, because I’m using KeyCDN
    Convert Both (Jpeg and PNG)
    Convertion method: Gd extention ( marked operational )

    I have Saved settings and pressed “Convert test image (show debug)” which linked to an image. I have also Inspected the page on Chrmoe but no image displays as WebP. Any idea how to make this work ?

    Also, I already have all images converted to WebP and stored on KeyCDN, all I need is to serve them

    Thank you!

Viewing 15 replies - 1 through 15 (of 16 total)
  • For CDN setup as per instructions provided by author it should be used option Alter Html and Replace image URLs, regards

    miculgigant

    (@miculgigant)

    Thanks for the reply, but actually this only makes the images disappear.

    From my understanding for CDN you either use “Varied image response” in case the CDN supports it, and mine doesn’t, or you use the “CDN friendly” option which should pretty much work out of the box…

    So I have no idea. Where did you see this mentioned ?

    Plugin Author rosell.dk

    (@roselldk)

    It is correct that you need to enable Alter HTML in “CDN friendly” mode, as n381 pointed out. Actually, I should consider forcing that option enabled in “CDN friendly” mode.

    Besides altering HTML, you also need to do something to get the images converted. As Bulk conversion is still on the roadmap, you need to activate the “Convert non-existing webp-files upon request” option or, if that doesn’t work for you, the “Convert non-existing webp-files upon request to original image (almost obsolete)” option.

    Plugin Author rosell.dk

    (@roselldk)

    Note that for the “Convert non-existing webp-files upon request” option to have effect, you must enable the “Reference webps that hasn’t been converted yet” option. Without those references to the non-existing webp-files, there will not be converted any images.

    I should consider displaying a warning if one has selected one of these options but not the other.

    miculgigant

    (@miculgigant)

    Thank you for the quick reply. It’s much appreciated.

    I will actually go a bit from the beginning, maybe things become a bit more clear for me and others than might be interested.

    I already have the images converted to webp by optimus.io from keyCDN and I also use keyCDN:

    https://www.miculgigant.ro/wp-content/uploads/2018/04/quarto.jpg
    https://www.miculgigant.ro/wp-content/uploads/2018/04/quarto.webp

    All I need is a seamless solution to serve the webp images to browsers that support it.

    The people that created optimus.io and keyCDN “offer” Cache Enabler that supposedly does this, but I’m happy with my current caching plugin…

    Any ideas on how I could go about this ?

    Plugin Author rosell.dk

    (@roselldk)

    Ok. I’m actually considering adding a new operation mode for situations where you do not need converting. (https://github.com/rosell-dk/webp-express/issues/172)

    Until then:
    – Use the “CDN friendly” mode
    – Enable Alter HTML
    – Select “Replace tags with <picture> tags, adding the webp to srcset”. You need this, because you are using page caching and you do not wish to switch to Cache Enabler
    – Set “Destination folder” to “mingled”
    – Set “File extension” to ‘Set to “.webp”‘ (to match Optimus)
    – Disable “Convert non-existing webp-files upon request (beta)”
    – Disable “Convert non-existing webp-files upon request to original image (almost obsolete)”

    • This reply was modified 11 months ago by rosell.dk.
    miculgigant

    (@miculgigant)

    It makes perfect sense now. It replaces <img> with <picture> and adds image.webp to srcset, which makes it 100% server independent and only browser dependent 🙂

    Much respect and love for your work, sir! Helps a lot

    • This reply was modified 11 months ago by miculgigant.
    Plugin Author rosell.dk

    (@roselldk)

    For others that might experience that it simply does not work, and are having no idea why:

    I just remembered an option I almost forgotten. If you switch to “Tweaked” mode, there is an option that is hidden in the other operation modes: “Do not pass source in Query String”. In the other modes, it is implicitly enabled. You can try disabling it.

    miculgigant

    (@miculgigant)

    Hello. I’m having a new problem 🙂

    Because of the tag change from to <picture> some of the things on my theme failed to work correctly.

    So, I gave up using the CDN for now and make it serve webp images using the Varied image responses.

    I also have “mingled”, file extension set to “.webp” and everything else not set.

    I’m on Cloudways and they say they have a unique configuration where they use both Apache and Nginx, Nginx being set as reverse proxy.

    And it seems like it doesn’t work, no webp images are getting displayed.

    Any idea ?

    Thank you!

    Plugin Author rosell.dk

    (@roselldk)

    Can you provide the URL?

    miculgigant

    (@miculgigant)

    Plugin Author rosell.dk

    (@roselldk)

    I see that you are on Cloudflare. It is problematic with Varied Image Responses. I have written about it in “I am on Cloudflare” section in the FAQ

    Plugin Author rosell.dk

    (@roselldk)

    How about choosing the other alter HTML option (replacing image urls rather than using picture tags). Replacing image url will not break styling. If you want page caching, you can complement with the Cache Enabler plugin

    miculgigant

    (@miculgigant)

    Ah yes! So far so good 🙂

    Why are there 2 options for Altering HTML ? I can understand this one, but not sure what the <picture> version brings new to the table.

    Already using WP Rocket for caching, feels better for some reason.

    Plugin Author rosell.dk

    (@roselldk)

    Well, the two methods have different pros and cons.

    picture tags:
    – Can break styles
    – Only works on img tags
    – Page caching is no problem

    image urls:
    – Does not break styles
    – Works on img tags, but also inline styles, lazy load and all kind of stuff
    – If you want page caching, you must use the Cache Enabler plugin

    Off for weekend. Good luck

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Simply not working and no idea why’ is closed to new replies.