WordPress.org

Support

Support » Plugins and Hacks » SimpleModal Login: Registration form is not working with BuddyPress

SimpleModal Login: Registration form is not working with BuddyPress

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hey.

    Try changing in Settings -> General , and in the line Membership , check the option anyone can register.
    when u open http://localhost/wordpress/register/ u get it. At least it worked for me just now, as i had the same issue.

    Hope it does the job. :p
    Bye!

    Buddypress makes the simplemodal plugin registration fail, because Buddypress takes over the default WP registration page by enforcing a redirect from all requests to the original regitration page /wp-login.php?action=register to Buddypress’ /register.

    The Buddypress registration form is very different from WP’s. It has different field names and BP requires you to pick a password, unlike standard WP (and simplemodal). So the form submission from simplemodal fails.

    You can fix this by disabling Buddypress’ redirect. This can be done by inserting this code into your bp-custom.php file:
    http://pastebucket.com/1415

    If you don’t know what bp-custom.php is, it is a file where you can put any customizations to buddypress. Read more here:
    http://codex.buddypress.org/extending-buddypress/bp-custom-php/

    lightrail
    Member

    @lightrail

    Thanks for the tip, rsm08! This is the only thing that worked for me. Modifying the theme & child theme’s functions.php files had no effect.

    I must say, I love BuddyPress, but it’s irritating that it hijacks the registration page. Now I can see the registration form as specified in Registration Plus Redux plugin settings.

    Thanks much for taking the time to post this information – very helpful.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘SimpleModal Login: Registration form is not working with BuddyPress’ is closed to new replies.