WordPress.org

Forums

[resolved] Simple Twitter Connect: Publish issues (7 posts)

  1. mferratusco
    Member
    Posted 4 years ago #

    I've installed the STC Publish plug-in. On the bottom-right corner of the Edit Post screen, in the Twitter Publisher window, when I click the Tweet button the progress meter continues to spin and the Tweet never gets posted. The Publisher plug-in gets hung up and nothing happens. Your help is greatly appreciated!

    Matt

  2. river35
    Member
    Posted 3 years ago #

    I'm having the exact same problem. The strange thing is that I've used the plugin very recently, on another website using a different hosting service, and it seemed to work fine there. Could there be some kind of server configuration issue going on?

  3. The very few times I've seen this, the person doing the setup had accidentally set up the Twitter application with "Read-Only" access.

    The fix for this is a a three stepper:

    1. Fix the application. Go to https://dev.twitter.com/apps and edit the app to have Read and Write access (you don't need DM access).

    2. Fix your credentials. Go to https://twitter.com/settings/applications , find your application, and Revoke the access.

    3. Go back to your site and go to the settings page and authenticate with Twitter again. Make sure it says Read and Write in the popup.

  4. river35
    Member
    Posted 3 years ago #

    Thanks for the response! The Twitter application had indeed gotten set to Read-Only somehow -- not sure what happened there, I was certain I'd chosen the Read & Write option while setting it up. This fix worked 100% for me, thanks again.

  5. craigzeller
    Member
    Posted 3 years ago #

    OK, I did have my Twitter App set to Read Only when I initially created it. I've changed my settings to Read and Write access. Then, I revoked access to my app from my site. I've since reset my keys and changed them in the plugin's settings. Also, I tried re-adding access to the app from my site. I get the never-ending spinning progress meter. Every time I click the button to enable auto-tweeting, I just get the message to authorize my app. I'm at a loss.

  6. skooby
    Member
    Posted 3 years ago #

    Hey Craig I was having the same problem. After you do the above steps, deactivate the STC - Publish plugin and then re-activate. After doing so, authenticate it again via the settings and it should work.

  7. Maarten
    Member
    Posted 3 years ago #

    Thanks for the support Otto, this was the solution for me too.

    Great plugin with the 'modules' by the way. I gave it a 5 star rating.

Topic Closed

This topic has been closed to new replies.

About this Topic