Support » Plugin: Simple Twitter Connect » Simple Twitter Connect and Live Blogging possible conflict?

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Try the trunk version. I renamed my Twitter OAuth library to avoid conflicts.

    Fatal error: Cannot redeclare class OAuthSignatureMethod_HMAC_SHA1 in /home/content/r/v/o/rvoodoo/html/voodoopress/wp-content/plugins/simple-twitter-connect/OAuth.php on line 82

    Here’s the error I’m getting after the upgrade to trunk

    Plugin Author Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Ugh. Okay, so he’s using the same library names.

    I added a class_exists check there, but I can’t guarantee the plugin will work if it’s using his oauth library instead of mine.

    Hi Otto,

    The TwitterOAuth library in Live Blogging is this one here: https://github.com/abraham/twitteroauth, are you using a home-made one, or re-using that library? If it’s the former, there’s quite a number of plugins that come with that library bundled so it’s going to be a problem with more than just Live Blogging!

    Regards,

    Chris Northwood (Live Blogging creator)

    do it work with previous version? … may be plugins is not compatible with new version of WP.

    ______________________
    Tim Viec LamTim Viec

    vnguru: The problem is because we both include the TwitterOAuth library, but slightly different versions of it, so it conflicts, not because of WP

    Plugin Author Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Chris, I’m using that one, but I modified mine to work better with WordPress and to be more compatible. The default library only supports curl, for example. Mine supports any of the transports WP’s HTTP API supports.

    Wow…. ok, so currently both are running on VoodooPress. Seems like a pretty unstable relationship.

    I uninstalled/reinstalled and deactivated/reactivated for days. It finally worked today. Except one issue.

    There is no way to authorize Live Blogging through twitter. I can live without it, but its a real bummer. If I try to authenticate Live Bloggin, it goes to twitters page, but when I click to allow it, I’m redirected back to my STC settings page.

    Do I have a hosed setting possibly?

    Thanks again for the help so far. I’d really love to get the 2 running, it’s a powerful combination!

    OK, so everything is currently working. Including liveblogging tweets.

    I had to activate STC first. And fully authorize it.

    Then activate liveblogging

    Then completely deactivate STC

    Authorize liveblogging

    Reactivate STC, the authorization made prior to deactivating will stick

    When done in that exact order, everything works….. for me

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Simple Twitter Connect and Live Blogging possible conflict?’ is closed to new replies.