WordPress.org

Support

Support » Plugins and Hacks » Simple Tags can’t work with WordPress 2.9 RC

Simple Tags can’t work with WordPress 2.9 RC

Viewing 15 replies - 1 through 15 (of 47 total)
  • Nothing in 2.9, as far as I can see, that will actually break Simple Tags. The error is thrown because the author has hardcoded a version check.

    If you edit the plugin via the editor interface, find this line (near the top):

    if ( strpos($wp_version, '2.7') !== false || strpos($wp_version, '2.8') !== false) {

    and change it to

    if ( strpos($wp_version, '2.7') !== false || strpos($wp_version, '2.8') !== false || strpos($wp_version, '2.9') !== false ) {

    bgunnink’s solution works! thanks a lot!

    I have a mistake in my Code?
    No Simple Tags are showing?

    // Check version.
    global $wp_version;
    if ( strpos($wp_version, '2.7') !== false || strpos($wp_version, '2.8') !== false || strpos($wp_version, '2.9') !== false ) {
    } elseif ( strpos($wp_version, '2.5') !== false || strpos($wp_version, '2.6') !== false  ) {
    	require(dirname(__FILE__).'/2.5/simple-tags.client.php');
    } elseif ( strpos($wp_version, '2.3') !== false ) {
    	require(dirname(__FILE__).'/2.3/simple-tags.client.php');
    } elseif ( strpos($wp_version, '2.2') !== false || strpos($wp_version, '2.1') !== false || strpos($wp_version, '2.0') !== false ) {
    	add_action('admin_notices', 'simple_tagging_warning');
    } else {
    	add_action('admin_notices', 'simple_tags_warning');
    }
    
    function simple_tagging_warning() {
    	echo '<div class="updated fade"><p><strong>'.__('Simple Tags can\'t work with this WordPress version !', 'simpletags').'</strong> '.sprintf(__('You must use <a href="%1$s">Simple Tagging Plugin</a> for it to work.', 'simpletags'), 'http://wordpress.org/extend/plugins/simple-tagging-plugin/').'</p></div>';
    }
    
    function simple_tags_warning() {
    	echo '<div class="updated fade"><p><strong>'.__('Simple Tags can\'t work with this WordPress version !', 'simpletags').'</strong></p></div>';
    }
    ?>

    Something wrong?
    Greetings
    Dieter

    Thx bgunnink, works like a charm!

    Dieter —

    You deleted part of the code that still needs to be there. It should look like this:

    // Check version.
    global $wp_version;
    if ( strpos($wp_version, '2.7') !== false || strpos($wp_version, '2.8') !== false || strpos($wp_version, '2.9') !== false ) {
    	require(dirname(__FILE__).'/2.7/simple-tags.client.php');
    } elseif ( strpos($wp_version, '2.5') !== false || strpos($wp_version, '2.6') !== false  ) {
    	require(dirname(__FILE__).'/2.5/simple-tags.client.php');
    } elseif ( strpos($wp_version, '2.3') !== false ) {
    	require(dirname(__FILE__).'/2.3/simple-tags.client.php');
    } elseif ( strpos($wp_version, '2.2') !== false || strpos($wp_version, '2.1') !== false || strpos($wp_version, '2.0') !== false ) {
    	add_action('admin_notices', 'simple_tagging_warning');
    } else {
    	add_action('admin_notices', 'simple_tags_warning');
    }

    You need to reinsert
    require(dirname(__FILE__).'/2.7/simple-tags.client.php'); before the first } elseif

    Thanks bgunnink. 🙂

    bgunnink
    Nothing in 2.9, as far as I can see, that will actually break Simple Tags…

    QFT, thank you very much for the quick solution, just started fixing all my websites 🙂

    Thanks:-)
    Now it runs…..

    Iva

    @supersonicsquirrel

    It still does not work for me. How come?

    Iva

    @supersonicsquirrel

    In other words, the function used to display tags on the front end is what doesn’t work. The above fix works only for the backend.

    Thank you very much, bgunnink. Nice as always.

    Thanks bgunnink, that works !

    Thanks a lot for your solution, bgunnink, it works perfectly!

    Thanks!

    Awesome – thanks bgunnink 🙂

Viewing 15 replies - 1 through 15 (of 47 total)
  • The topic ‘Simple Tags can’t work with WordPress 2.9 RC’ is closed to new replies.
Skip to toolbar