WordPress.org

Forums

Simple Tags
Simple Tags breaks tag-based post queries in WP trunk (3 posts)

  1. ramenboy
    Member
    Posted 4 years ago #

    I ran into the following issue with Simple Tags on WordPress trunk

    http://core.trac.wordpress.org/ticket/12891#comment:73

    Enabling Simple Tags on WordPress trunk causes queries of the form get_posts('tag=something') return all posts rather than just those tagged "something".

    Though this problem was introduced by a recent change to WordPress, it seems like Simple Tags is causing the problem by overwriting the value of 'query_var' with '' in $GLOBALS['wp_taxonomies']. The following diff shows what $GLOBALS['wp_taxonomies'] looks like on a fresh WP trunk installation before and after enabling Simple Tags:

    http://gist.github.com/659120

    It seems like Simple Tags should at least ensure that these parameters are set to reasonable values, though I don't understand why it is necessary to call register_taxonomy() at all, since taxonomy.php already does this.

    Thanks for your consideration,
    Dave

    http://wordpress.org/extend/plugins/simple-tags/

  2. senator94
    Member
    Posted 4 years ago #

    I am have the same problem using WordPress 3.1-beta2. I hope there is a fix soon.

  3. ramenboy
    Member
    Posted 4 years ago #

    I posted a patch here, which fixes the problem for me:

    http://redmine.beapi.fr/issues/182

    The author responded and said it was fixed in the 2.0.0 release.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic